Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001468 [DCSS] FR: Interface Improvements minor have not tried 2010-05-02 17:28 2013-10-11 03:02
Reporter rob View Status public  
Assigned To SamB
Priority normal Resolution done  
Status resolved   Product Branch 0.7 ancient branch
Summary 0001468: forced more should interrupt travel
Description You can do this now by duplicating every force_more_message to a runrest_stop_message, but it seems sensible to handle this differently.

Not sure what the right way to do this would be. Maybe issue AI_FORCED_MORE from message.cc:more if force is set?
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0004551)
dpeg (administrator)
2010-05-02 21:01

Yes. All messages with force_more should interrupt travel.

While we're at it, could (first!) announcements for timed portal vaults get a force_more by default?
(0024183)
SamB (developer)
2013-10-11 03:02

I actually have no idea when this was fixed, but it seems to be, so ...

- Issue History
Date Modified Username Field Change
2010-05-02 17:28 rob New Issue
2010-05-02 21:01 dpeg Note Added: 0004551
2013-10-11 03:02 SamB Note Added: 0024183
2013-10-11 03:02 SamB Status new => resolved
2013-10-11 03:02 SamB Fixed in Branch => 0.14 development branch
2013-10-11 03:02 SamB Resolution open => done
2013-10-11 03:02 SamB Assigned To => SamB


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker