Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000144 [DCSS] Source Cleanup major have not tried 2009-12-08 11:25 2015-04-14 18:32
Reporter rob View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status closed   Product Branch
Summary 0000144: sort out handling of coloured strings
Description Tagged strings need a separate data type from std::string.

They should only occur within data files, and never be generated by code.

Internally, coloured strings should fit in some tree-like representation of such a marked-up string. formatted_string isn't adequate.

std::string objects should never be treated as marked up outside the data file reading routines.
Additional Information
Tags No tags attached.
Attached Files

- Relationships
related to 0002092acknowledged < doesn't work in force message prompt 

-  Notes
(0000336)
rob (developer)
2009-12-08 15:24

It turns out that formatted_string can't handle this, since it's just a flat sequence of "operations". We need a new data structure to store marked-up strings:

A tagged string is a tree-like thing: sequence of one or more parts, each of which can be either a piece of plain text (a plain std::string) or a tag together with a tagged string.
(0006735)
KiloByte (manager)
2010-07-30 11:46

Perhaps we could keep the markup, but use some invalid character instead? It would let us keep using simple types, while getting rid of < escaping issues.
(0028862)
MarvinPA (developer)
2015-04-14 18:32

Closing some old FRs, these might still be desirable but they don't need to have Mantis issues for them.

- Issue History
Date Modified Username Field Change
2009-12-08 11:25 rob New Issue
2009-12-08 15:24 rob Note Added: 0000336
2010-07-30 11:36 rob Relationship added related to 0002092
2010-07-30 11:42 rob Summary get rid of programmatically generated colour markup => sort out handling of coloured strings
2010-07-30 11:42 rob Description Updated
2010-07-30 11:42 rob Severity minor => major
2010-07-30 11:46 KiloByte Note Added: 0006735
2015-04-14 18:32 MarvinPA Note Added: 0028862
2015-04-14 18:32 MarvinPA Status new => resolved
2015-04-14 18:32 MarvinPA Fixed in Branch => 0.16 pre-release branch
2015-04-14 18:32 MarvinPA Resolution open => done
2015-04-14 18:32 MarvinPA Assigned To => MarvinPA
2015-04-14 18:32 MarvinPA Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker