Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000014 [DCSS] Bug Report minor always 2009-11-22 19:52 2009-11-25 18:12
Reporter Kliff View Status public  
Assigned To KiloByte
Priority normal Resolution done  
Status closed   Product Branch 0.6 ancient branch
Summary 0000014: Scythe of reaping brand not working as intended.
Description Taken from 0.6.0-a1-933-gcbf4418, ASCII version, playing on Wizmode locally.

I found a Scythe of Reaping on Sigmund, killed him, picked it up and started killing with it, but the reaping brand doesn't seem to be working. A look at the scythe's description, and it says, quote:

"If ammo fired by it kills a monster, causing it to leave a corpse, the corpse will be animated as a zombie friendly to the one who fired it."

As far as I can tell, scythes don't have ammo.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0000025)
jpeg (manager)
2009-11-22 22:47

I think reaping was given to scythes as an afterthought. AFAIR, the brand was not originally intended to work on non-launchers. I like the idea of scythes of reaping, though, so I think this should be fixed.
(0000081)
KiloByte (manager)
2009-11-25 14:06

Someone forced a ranged-only brand on scythes.
I extended it to work for melee weapons as well.
(0000085)
Napkin (administrator)
2009-11-25 18:12

Sorry for the spam!

- Issue History
Date Modified Username Field Change
2009-11-22 19:52 Kliff New Issue
2009-11-22 19:52 Kliff Test Custom Field => Foo
2009-11-22 22:47 jpeg Note Added: 0000025
2009-11-22 22:47 jpeg Severity major => minor
2009-11-22 22:47 jpeg Status new => acknowledged
2009-11-22 22:47 jpeg Issue Monitored: jpeg
2009-11-25 14:06 KiloByte Note Added: 0000081
2009-11-25 14:06 KiloByte Reproducibility have not tried => always
2009-11-25 14:06 KiloByte Status acknowledged => closed
2009-11-25 14:06 KiloByte Resolution open => done
2009-11-25 17:48 Napkin Fixed in Branch => 0.6 development branch
2009-11-25 18:11 Napkin Status closed => assigned
2009-11-25 18:11 Napkin Assigned To => KiloByte
2009-11-25 18:12 Napkin Note Added: 0000085
2009-11-25 18:12 Napkin Status assigned => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker