Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0012522 [DCSS] Bug Report minor have not tried 2021-02-26 15:10 2021-03-10 00:20
Reporter Yermak View Status public  
Assigned To ebering
Priority normal Resolution done  
Status closed   Product Branch 0.27 development version
Summary 0012522: Some potions are split into two stacks.
Description  c - 8 potions of magic
 j - 4 potions of heal wounds
 l - 8 potions of flight
 n - 14 potions of curing
 C - 3 potions of invisibility
 G - 4 potions of ambrosia
 H - 3 potions of haste
 J - 5 potions of cancellation
 K - 8 potions of resistance
 L - 6 potions of berserk rage
 N - 5 potions of heal wounds
 Q - 4 potions of curing
 Y - 3 potions of might
Additional Information
Tags No tags attached.
Attached Files txt file icon Goratrix.txt [^] (16,525 bytes) 2021-02-28 16:38 [Show Content]
? file icon Goratrix.cs [^] (339,772 bytes) 2021-02-28 16:38
png file icon Screenshot 2021-03-01 162548.png [^] (13,768 bytes) 2021-03-01 16:29


txt file icon andrew.txt [^] (23,556 bytes) 2021-03-04 16:28 [Show Content]

- Relationships

-  Notes
(0034149)
ebering (developer)
2021-02-26 15:12

Can you include a char dump? This might be a save compatibility issue and the version strings would help sort it out.
(0034150)
Yermak (reporter)
2021-02-26 18:52

Sorry, it's too late. But I'm sure I hadn't saved/resumed game from its start until I noticed it. Also I'm pretty sure both potions in question I identified by buying from shop and I didn't have them in my inventory at the moment of purchase.
(0034160)
Goratrix (reporter)
2021-02-28 16:37

I just had the same issue in current trunk (0.27-a0-463-gec7707c53d), save and morgue attached. Game was started in the same version, so it's not a save compat problem. Also I can confirm that I identified the first one by buying it in a shop, same as Yermak mentioned.

4597 | D:5 | Bought a potion of heal wounds for 75 gold pieces

f - 5 potions of heal wounds
s - a potion of heal wounds
(0034164)
Goratrix (reporter)
2021-03-01 16:28

Got it again, attached is a screenshot of the sequence. Looks like the unidentified stack was on 'u'. I bought 5 of the scrolls, first one (which identified it) went to a different letter 'S' and then the other ones went again to 'u'.
(0034168)
andrew (reporter)
2021-03-04 16:29

I have the same issue. Morgue attached. Noticed it after buying an identified !lignification, with an unidentified in inventory.
(0034177)
Goratrix (reporter)
2021-03-08 20:00

Just tested with https://github.com/crawl/crawl/commit/328d1db4bdc42db85ce6428564f07a58ce46e9e6 [^] and this looks to be fixed, thanks!
(0034178)
ebering (developer)
2021-03-08 21:19

Fixed!

- Issue History
Date Modified Username Field Change
2021-02-26 15:10 Yermak New Issue
2021-02-26 15:12 ebering Note Added: 0034149
2021-02-26 18:52 Yermak Note Added: 0034150
2021-02-28 16:37 Goratrix Note Added: 0034160
2021-02-28 16:38 Goratrix File Added: Goratrix.txt
2021-02-28 16:38 Goratrix File Added: Goratrix.cs
2021-03-01 16:28 Goratrix Note Added: 0034164
2021-03-01 16:29 Goratrix File Added: Screenshot 2021-03-01 162548.png
2021-03-04 16:28 andrew File Added: andrew.txt
2021-03-04 16:29 andrew Note Added: 0034168
2021-03-08 20:00 Goratrix Note Added: 0034177
2021-03-08 21:19 ebering Note Added: 0034178
2021-03-08 21:19 ebering Status new => resolved
2021-03-08 21:19 ebering Resolution open => done
2021-03-08 21:19 ebering Assigned To => ebering
2021-03-10 00:20 Yermak Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker