Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0012260 [DCSS] Bug Report crash always 2020-05-12 05:01 2020-06-24 00:08
Reporter aaron View Status public  
Assigned To advil
Priority normal Resolution done  
Status resolved   Product Branch 0.25 stable branch
Summary 0012260: another screen write out of bounds
Description ERROR in 'libutil.cc' at line 390: screen write out of bounds: (1,36) into (139,35)

We crashed! This is likely due to a bug in Crawl.
Please submit a bug report at https://crawl.develz.org/mantis/ [^] and include:
- The crash report: /home/ape/.crawl/morgue/crash-Natwop-20200511-214905.txt
- Your save file: /home/ape/.crawl/saves/Natwop.cs
- A description of what you were doing when this crash occurred.

Aborted

...

I'm using Konsole on Debian.

If I resume a game, then shrink the console window, then do 'ff' with nobody around, it crashes reliably with the above message, on multiple characters.
Probably related to other open issues most recently https://crawl.develz.org/mantis/view.php?id=11981 [^]

thank you
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0033803)
advil (administrator)
2020-05-12 23:21

looks like this report goes together with the screenshots here: https://crawl.develz.org/tavern/viewtopic.php?p=344122#p344122 [^]
(0033804)
advil (administrator)
2020-05-12 23:37
edited on: 2020-05-12 23:38

I was able to replicate this (edit: on mac terminal), but not very consistently. Here's a stack trace (this was from hitting S, not ff, but the effect is probably similar):

Crash caused by signal 0000011: Segmentation fault: 11

Obtained 19 stack frames.
0x00000001066b1bc9: write_stack_trace(__sFILE*) + 265
0x00000001066daeb8: do_crash_dump() + 2168
0x00000001066b1908: crash_signal_handler(int) + 1064
0x00007fff7de1fb5d: _sigtramp + 29
0x00007ffee981bbf0: 0x0 + 140732816014320
0x00000001066df475: die(char const*, int, char const*, ...) + 581
0x0000000106f3b2ba: cgotoxy(int, int, GotoRegion) + 250
0x0000000107b838cb: ui::clear_text_region(ui::Region, COLOURS) + 235
0x0000000107b8ab32: ui::UIRoot::render() + 194
0x0000000107b8c9ac: ui::pump_events(int) + 92
0x0000000107b8ce75: ui::getch(KeymapContext) + 197
0x000000010763f520: yesno(char const*, bool, int, bool, bool, bool, std::__1::map<int, int, std::__1::less<int>, std::__1::allocator<std::__1::pair<int const, int> > > const*) + 2016
0x0000000107db70b4: process_command(command_type) + 6868
0x0000000107dcb6a2: _input() + 2930
0x0000000107dc95fd: _launch_game() + 909
0x0000000107db52de: _launch_game_loop() + 62
0x0000000107db4c68: main + 408
0x00000001063e76cc: start + 52
0x0000000000000001: 0x0 + 1

(0033805)
aaron (reporter)
2020-05-13 23:56

yes those are the screenshots. i just checked and it happens on all my other virtual terminals also (LXTerminal, UXTerm, XTerm).

i killed the mummy priest again so nothing lost.
(0033839)
advil (administrator)
2020-06-24 00:07

Belated update, this was fixed in: https://github.com/crawl/crawl/commit/0714e02a209a [^]

- Issue History
Date Modified Username Field Change
2020-05-12 05:01 aaron New Issue
2020-05-12 23:21 advil Note Added: 0033803
2020-05-12 23:37 advil Note Added: 0033804
2020-05-12 23:37 advil Status new => confirmed
2020-05-12 23:38 advil Note Edited: 0033804
2020-05-13 23:56 aaron Note Added: 0033805
2020-06-24 00:07 advil Note Added: 0033839
2020-06-24 00:07 advil Status confirmed => resolved
2020-06-24 00:07 advil Fixed in Branch => 0.25 stable branch
2020-06-24 00:07 advil Resolution open => done
2020-06-24 00:07 advil Assigned To => advil


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker