Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011876 [DCSS] Bug Report crash always 2019-02-12 17:10 2019-02-12 18:42
Reporter user6518 View Status public  
Assigned To amalloy
Priority normal Resolution done  
Status resolved   Product Branch 0.23 stable branch
Summary 0011876: Crash when going down particular stairs
Description Kill the shapeshifter, then go down the Easternmost staircase. The game then crashes.
Additional Information
Tags No tags attached.
Attached Files ? file icon Aptiti.cs [^] (669,162 bytes) 2019-02-12 17:10

- Relationships

-  Notes
(0033087)
user6518
2019-02-12 17:17
edited on: 2019-02-12 17:25

Edit: It looks like floor 14 can't be accessed by any methods - I can't go down stairs, can't shaft into it, can't use wizard mode to shaft to 15 then go up stairs.

I want to complete the game with this character, so if it's an item or monster causing the crash I'd appreciate it if you could edit the save to remove it.

(0033088)
djt190ps5 (reporter)
2019-02-12 17:52

Why the hell was my account banned for adding this bug? Because I asked, as an afterthought, for my save to be edited?
(0033089)
amalloy (developer)
2019-02-12 18:42

I don't know what's going on with that account being deleted. I can't imagine any human doing it, so I expect it was some sort of automated system - maybe spam prevention gone wrong? I don't have any superpowers on Mantis so I can't put it back. If the user6518 account is important to you (I mention this because the name suggests it might not be), I suggest following up with a Mantis admin, maybe by filing a Mantis bug?

As to your actual bug report: that's a cool one. It turns out that the water nymph had temporarily transformed both the Vaults entrance and the up-stair on D:14 to shallow water, causing a sanity check when level loading to fail. I've fixed that sanity check to account for the possibility of temporary terrain changes, in https://github.com/crawl/crawl/commit/cea5463b436e. [^] If you update to a version at least as new as that, your save will continue working as normal, with no need to fix the save.

- Issue History
Date Modified Username Field Change
2019-02-12 17:10 user6518 New Issue
2019-02-12 17:10 user6518 File Added: Aptiti.cs
2019-02-12 17:17 user6518 Note Added: 0033087
2019-02-12 17:25 user6518 Note Edited: 0033087
2019-02-12 17:52 djt190ps5 Note Added: 0033088
2019-02-12 18:42 amalloy Note Added: 0033089
2019-02-12 18:42 amalloy Status new => resolved
2019-02-12 18:42 amalloy Fixed in Branch => 0.24 development branch
2019-02-12 18:42 amalloy Resolution open => done
2019-02-12 18:42 amalloy Assigned To => amalloy


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker