Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011865 [DCSS] Bug Report crash have not tried 2019-02-08 17:10 2019-02-09 16:36
Reporter MeanWeen View Status public  
Assigned To advil
Priority normal Resolution duplicate  
Status resolved   Product Branch 0.23 stable branch
Summary 0011865: ASSERT(!place_info.is_global()) in 'tags.cc' at line 4209 failed.
Description Updated a save from 0.21 to 0.23 and it worked fine until I saved and started the game up a second time. From that point on it would not load.
Additional Information
Tags No tags attached.
Attached Files ? file icon Berg.cs [^] (612,477 bytes) 2019-02-08 17:10
txt file icon crash-Berg-20190208-073921.txt [^] (5,346 bytes) 2019-02-08 17:13 [Show Content]
? file icon Berg_fixed.cs [^] (612,477 bytes) 2019-02-08 23:19

- Relationships
duplicate of 0011863new Save files corrupted by update to 23.0 

-  Notes
(0033066)
MeanWeen (reporter)
2019-02-08 17:14

I see now that this bug report was already submitted in the time I took to build one. My mistake!
(0033072)
advil (administrator)
2019-02-08 21:41

Thanks for the report, I can probably fix this save once I've figured out what's going on. Do you know what version exactly this was upgrading from?
(0033073)
advil (administrator)
2019-02-08 23:20

I've attached a fixed version of this save that has been upgraded to 0.23.0, let me know if you have any trouble with it. (I do know more or less what's going on, it's related to an old bug about upgrading when a new branch has been added, in this case gauntlet. It'll take me a while longer to get a fix, and we'll incorporate that into a 0.23.1 release sometime after the tournament, but hand-fixing individual save games isn't too hard.)
(0033079)
advil (administrator)
2019-02-09 16:36

Marking as a duplicate, but definitely feel free to post an update here or in the other mantis thread if there are more problems.

- Issue History
Date Modified Username Field Change
2019-02-08 17:10 MeanWeen New Issue
2019-02-08 17:10 MeanWeen File Added: Berg.cs
2019-02-08 17:13 MeanWeen File Added: crash-Berg-20190208-073921.txt
2019-02-08 17:14 MeanWeen Note Added: 0033066
2019-02-08 21:41 advil Note Added: 0033072
2019-02-08 23:19 advil File Added: Berg_fixed.cs
2019-02-08 23:20 advil Note Added: 0033073
2019-02-09 16:36 advil Note Added: 0033079
2019-02-09 16:36 advil Relationship added duplicate of 0011863
2019-02-09 16:36 advil Duplicate ID 0 => 11863
2019-02-09 16:36 advil Status new => resolved
2019-02-09 16:36 advil Fixed in Branch => 0.24 development branch
2019-02-09 16:36 advil Resolution open => duplicate
2019-02-09 16:36 advil Assigned To => advil


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker