Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011838 [DCSS] Bug Report minor have not tried 2019-01-22 02:36 2019-03-02 00:32
Reporter kitchen_ace View Status public  
Assigned To advil
Priority normal Resolution done  
Status closed   Product Branch 0.23 stable branch
Summary 0011838: Reading notes with ?: starts at top of list
Description Pressing ?: in webtiles to read notes starts at the top of the list of notes, instead of at the bottom where it should to be. Can't reproduce in Linux local tiles or online console.

Here's a save in case it helps:

http://crawl.kelbi.org/saves/EthnicCake-crawl-git-6debee6d2d-190122-0131.tar.bz2 [^]
Additional Information
Tags No tags attached.
Attached Files

- Relationships
has duplicate 0011854resolvedadvil [Ctrl+p] history starts at top,not at bottom 

-  Notes
(0032955)
floraline (reporter)
2019-01-22 02:57

I also noticed this in the Ctrl+P message log. The dialog box always starts at the top of the log. This happens in Firefox but not Chrome. When scrolling this dialog box, the following message is printed in the Firefox developer console:

This site appears to use a scroll-linked positioning effect. This may not work well with asynchronous panning; see https://developer.mozilla.org/docs/Mozilla/Performance/ScrollLinkedEffects [^] for further details and to join the discussion on related tools and features!
(0032956)
ebering (developer)
2019-01-22 03:08

Webdev issues aside, this issue replicates in console.
(0033050)
advil (administrator)
2019-02-06 15:43

I believe I have fixed this in https://github.com/crawl/crawl/commit/dd71560323a7 [^]

Part of the variation in reports is that the behavior was determined by uninitialized variables, so would appear quite random depending on compiler behavior and probably system memory state at the time. I'm not entirely sure why this reports only popped up recently as this isn't a new problem.

As far as I could figure out, there's nothing specific to webtiles or to a particular browser about this (maybe something about how different browsers handle large numbers) -- it's just varying from case to case because of the above issue. I did a quick test in firefox and chrome and the behavior should now be the same, but this issue can be reopened if I'm wrong.

- Issue History
Date Modified Username Field Change
2019-01-22 02:36 kitchen_ace New Issue
2019-01-22 02:57 floraline Note Added: 0032955
2019-01-22 03:08 ebering Note Added: 0032956
2019-01-22 03:09 ebering Status new => confirmed
2019-02-06 15:26 advil Relationship added has duplicate 0011854
2019-02-06 15:43 advil Note Added: 0033050
2019-02-06 15:43 advil Status confirmed => resolved
2019-02-06 15:43 advil Fixed in Branch => 0.23 development branch
2019-02-06 15:43 advil Resolution open => done
2019-02-06 15:43 advil Assigned To => advil
2019-03-02 00:31 kitchen_ace Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker