Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011834 [DCSS] Bug Report minor always 2019-01-20 16:13 2019-03-18 22:06
Reporter Laret View Status public  
Assigned To advil
Priority normal Resolution done  
Status resolved   Product Branch 0.23 stable branch
Summary 0011834: meatsprint is VERY easy
Description As compared to 0.21, in which I could never win the Arena of Blood, the current trunk meatsprint is almost trivially easy, played as a Centaur Warper.

Grab axe, pray at right altar, head to right wall, grab ring, head to bottom wall, grab ring, head back to middle, easily kill boss, win.

It's possible that the bug was that it was too hard in 0.21? :) But it does seem VERY easy now in trunk.
Additional Information
Tags No tags attached.
Attached Files

- Relationships
has duplicate 0011927resolvedadvil Sprint module Arena of Blood no longer spawns most enemies 

-  Notes
(0033040)
advil (administrator)
2019-02-03 18:19

Yeah, meatsprint broke. This seems to be because of a change in how teleport traps work in 0.23; this sprint uses permanent tele traps to distribute monsters throughout the level, but because these are all revealed now, high level monsters never move into them, and also don't tele when they spawn in the secret closet. This room also can get clogged enough that nothing new spawns in there. I'm not immediately sure what the fix is.
(0033041)
advil (administrator)
2019-02-03 18:53

oh, more accurate localizing of the problem: tele traps don't do anything any more unless the player is in los -- https://github.com/crawl/crawl/commit/66906bf02876 [^] .
(0033187)
advil (administrator)
2019-03-18 22:06

This is fixed (modulo any further necessary rebalancing) in: https://github.com/crawl/crawl/commit/62cde1d77f50 [^]

- Issue History
Date Modified Username Field Change
2019-01-20 16:13 Laret New Issue
2019-01-21 18:50 Laret Issue Monitored: Laret
2019-02-03 18:19 advil Note Added: 0033040
2019-02-03 18:19 advil Status new => confirmed
2019-02-03 18:53 advil Note Added: 0033041
2019-03-18 14:18 advil Relationship added has duplicate 0011927
2019-03-18 22:06 advil Note Added: 0033187
2019-03-18 22:06 advil Status confirmed => resolved
2019-03-18 22:06 advil Fixed in Branch => 0.24 development branch
2019-03-18 22:06 advil Resolution open => done
2019-03-18 22:06 advil Assigned To => advil


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker