Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011831 [DCSS] Bug Report trivial always 2019-01-17 08:07 2019-02-02 10:09
Reporter kitchen_ace View Status public  
Assigned To ebering
Priority normal Resolution no change required  
Status closed   Product Branch 0.23 old branch
Summary 0011831: Transmutation spells can show max duration
Description Commit https://github.com/crawl/crawl/commit/19699f695db2ddd37a155121367c3435a6f0a504 [^] says "The information that the player has maxed out their duration is not given to the player for other spells," however this is not true of transmutation spells at high power. Necromutation is the most obvious of these because it takes very high spell skills to cast, and gives itself a power boost on recasting.

I'm not sure if these spells are overlooked or not, but that commit suggests they are.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0032945)
NormalPerson7 (reporter)
2019-01-17 10:23
edited on: 2019-01-17 11:27

I think these spells also should not give away this information, for the reasons outlined in that commit. More specifically, giving the player the information that their duration is maxed out allows them to calculate the exact turn on which it will run out potentially tens or hundreds of turns in advance, which Crawl generally tries to avoid.

(0033028)
ebering (developer)
2019-02-01 20:18

These spells were not overlooked. Casting a form will attempt to extend the duration, print a message if successful or not, and in either case return spret::success, deducting the casting costs.

- Issue History
Date Modified Username Field Change
2019-01-17 08:07 kitchen_ace New Issue
2019-01-17 10:23 NormalPerson7 Note Added: 0032945
2019-01-17 11:27 NormalPerson7 Note Edited: 0032945
2019-02-01 20:18 ebering Note Added: 0033028
2019-02-01 20:18 ebering Status new => resolved
2019-02-01 20:18 ebering Resolution open => no change required
2019-02-01 20:18 ebering Assigned To => ebering
2019-02-02 10:08 kitchen_ace Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker