Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011814 [DCSS] Bug Report minor always 2019-01-03 19:33 2019-02-04 18:45
Reporter Siegurt View Status public  
Assigned To ebering
Priority normal Resolution done  
Status closed   Product Branch 0.23 old branch
Summary 0011814: Pain's message inconsistent against invisible creatures
Description So all the other attack spells give an indicator when you hit an unseen creature with them, pain is notable in that hit or miss you get "Nothing appears to happen" this seems like a weird exception in and of itself, however when you kill something the message "Nothing appears to happen" occurs after you kill something aka:

Casting: Pain (safe; 2% risk of failure)
Confirm with . or Enter, or press ? or * to list all spells.
Aiming: Pain (safe; 2% risk of failure)
Press: ? - help, Shift-Dir - straight line
Nothing appears to happen. Something hits you but does no damage.
Casting: Pain (safe; 2% risk of failure)
Confirm with . or Enter, or press ? or * to list all spells.
Aiming: Pain (safe; 2% risk of failure)
Press: ? - help, Shift-Dir - straight line
Reactivating autopickup.
You feel a bit more experienced. Nothing appears to happen.

It's a little odd/awkward in and of itself that pain intentionally gives you no indication of if you're hitting the right square or not (unlike other attack spells and weapons) but it's also clearly weird/awkward phrasing for the "Nothing appears to happen" message to be printed right after something drops dead at your feet.

I do get that both definition-wise and "flavor wise" pain is an enchantment on the monster rather than a standard attack (The rational being that you're not throwing something at them that needs to hit, but rather directing that something happen to them, like with confuse) and enchantments you can really usually only tell if they succeeded if you can see the target.

However since pain is functionally an attack spell, maybe we can make pain be an enchantment that gets attack-like messages, out of sheer practicality something like "bathed in an unholy light" which might logically be applied to something you can't see.

At very least I'd like enchantments that can cause death to not spit out "Nothing appears to happen" messages if it kills something, because it's just weird.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0033010)
ebering (developer)
2019-01-27 00:08

0.23-a0-850-g4a3ee90

- Issue History
Date Modified Username Field Change
2019-01-03 19:33 Siegurt New Issue
2019-01-27 00:08 ebering Note Added: 0033010
2019-01-27 00:08 ebering Status new => resolved
2019-01-27 00:08 ebering Resolution open => done
2019-01-27 00:08 ebering Assigned To => ebering
2019-02-04 18:44 Siegurt Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker