Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011806 [DCSS] Bug Report minor have not tried 2018-12-27 13:59 2019-01-27 00:09
Reporter Sar View Status public  
Assigned To ebering
Priority normal Resolution done  
Status resolved   Product Branch 0.23 old branch
Summary 0011806: Weird interaction between Shadow Step, Nightstalker (?) and dispersal trap
Description I was playing a Ds with Nightstalker 3, and trying to use Shadow Step on an OCS at the edge of my los activated a "Are you sure you want to step into a dispersal trap?" prompt and revealed said dispersal trap which was behind the OCS (I think?). Even if it wasn't, it's weird that it allowed me to cancel the Shadow Step, since it's random where it would place me.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0032884)
NormalPerson7 (reporter)
2018-12-28 19:17

I did some testing on this.

When shadow stepping to an enemy standing next to any trap, the game *always* prompts about placing you on the trap, regardless of where you are actually placed. IMO this should be clarified by changing the prompt to something like "Really shadow step near the <trap type> trap?" This applies when you know of a trap next to the monster, regardless of whether the trap is in line of sight, and this behaviour is probably desirable (apart from the prompt issue).

When shadow stepping to a monster on the explore horizon next to a trap on a tile you have not explored before, the game still prompts you about that trap despite the fact that you do not know of it. This information leak is extremely minor since traps are revealed as soon as you enter their line of sight, but it should probably be changed to not leak this information.

Further testing reveals that the prompt for shadow-stepping where there is an unseen tile with a trap on is inconsistent: if the trap is a Zot, teleport or dispersal trap, the trap's type is given in the prompt, whereas if the trap is mechanical and a prompt would be given for walking over the trap (this is based on your current HP), the extremely awkward prompt "Really shadow step onto the floor?" is given, which is definitely a bug.

Note that reproducing the effects in the bottom two paragraphs using wizmode is awkward because it is impossible to mark already explored areas of the map as completely unseen as far as I can tell. I recommend using Zot:5 for testing given the high number of guaranteed traps there, while under &E and a normal scroll of magic mapping - do not use &{ since this will reveal the traps.
(0032925)
NormalPerson7 (reporter)
2019-01-13 10:28

Since the changes to mechanical traps etc, it might also be helpful to use Ossuary to test this now.
(0033012)
ebering (developer)
2019-01-27 00:08

Fixed in 0.23-a0-852-g83ee88d

- Issue History
Date Modified Username Field Change
2018-12-27 13:59 Sar New Issue
2018-12-28 19:17 NormalPerson7 Note Added: 0032884
2019-01-13 10:28 NormalPerson7 Note Added: 0032925
2019-01-14 02:54 naijabangmedia Note Added: 0032926
2019-01-14 02:55 ebering Note Deleted: 0032926
2019-01-27 00:08 ebering Note Added: 0033012
2019-01-27 00:08 ebering Status new => resolved
2019-01-27 00:08 ebering Resolution open => done
2019-01-27 00:08 ebering Assigned To => ebering


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker