Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011792 [DCSS] Bug Report major always 2018-12-17 16:13 2019-01-27 00:09
Reporter NormalPerson7 View Status public  
Assigned To ebering
Priority normal Resolution done  
Status resolved   Product Branch 0.23 stable branch
Summary 0011792: Issues when initially worshipping Jiyva
Description Firstly, a clear bug:

If the player manages to find a hostile slime/eye creature (a real one, not a shapeshifter), while worshipping Jiyva, and attempts to attack that slime/eye, they will be prompted "Really attack X? This attack would place you under penance." but in fact Jiyva does not care about the player making the attack, nor killing the slime/eye entirely.

Secondly, possibly a bug and possibly intended, but combined with the above bug is an issue:

When the player initially worships Jiyva, any slimes/eyes they have already encountered will not turn neutral to them and instead remain hostile.

These two combined mean that if the player worships Jiyva through the vault slime_altar_2 which spawns in Lair, the slimes in that vault will not turn neutral and the player apparently cannot attack them because they are incorrectly told this places them under penance.

Thanks to Spaninq for this, who unfortunately lost a character attempting to worship Jiyva as a result of this interaction. Since this bug has the potential to be lethal, I am marking it as major.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0032863)
NormalPerson7 (reporter)
2018-12-19 18:02

It seems this does place you under penance when you kill slimes/eyes now, I'm not sure how I failed on my previous test. This means the first thing isn't a bug but the second thing shouldn't happen because it produces hostile monsters that cannot be killed.
(0032923)
ebering (developer)
2019-01-12 18:20

This is probably a consequence of some of the god conversion changes that only run the conversion attempt the first time you see the monster. Jiyva should definitely always neutralize slimes, it might be good to do the conversion not on sight (like Beogh and Gozag bribes) but on level-load and on conversion.
(0033013)
ebering (developer)
2019-01-27 00:09

Fixed in 0.23-a0-853-gfe5b60b

- Issue History
Date Modified Username Field Change
2018-12-17 16:13 NormalPerson7 New Issue
2018-12-19 18:02 NormalPerson7 Note Added: 0032863
2019-01-12 18:20 ebering Note Added: 0032923
2019-01-27 00:09 ebering Note Added: 0033013
2019-01-27 00:09 ebering Status new => resolved
2019-01-27 00:09 ebering Resolution open => done
2019-01-27 00:09 ebering Assigned To => ebering


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker