Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011780 [DCSS] Bug Report major random 2018-12-06 07:02 2019-02-08 18:58
Reporter RoGGa View Status public  
Assigned To ebering
Priority normal Resolution done  
Status closed   Product Branch 0.23 stable branch
Summary 0011780: enemy or Hep ancestor icon is not erased (also, player icon during autotravel)
Description on CKO in trunk under RoGGa as a OgSu

I'll attach a screen capture when I come across this bug a 4th time.

The 1st time, my Hep ancestor got 2 icons. One wasn't removed when it moved.

The 2nd and 3rd time was a monster's icon did not disappear after it had died.

In all 3 instances, the icon disappeared when my character walked onto that tile.
Additional Information
Tags No tags attached.
Attached Files

- Relationships
related to 0011283resolvedebering Dark areas in Shoals look totally black 
related to 0011776resolvedebering Webtiles UI sometimes bugs and doesn't show the current situation 
related to 0011762closedebering Map displays image of a plant from another floor. 

-  Notes
(0032892)
jejorda2 (reporter)
2018-12-31 13:38

I'm seeing the same thing repeatedly on 0.23-a0-643-g9ccc95a web tiles on CBO. I tab to kill an enemy, "you kill the bat" is in the message log, tab gives me "No target in view," bat tile is visible next to my player, bat tile and name is in the enemies list. Ctrl-x lists a bat corpse (with the right tile.) This has happened a dozen times with different enemies in the past two games. I usually play console and don't see this.
(0032895)
RoGGa (reporter)
2019-01-02 02:20

The only time when this seems to still occur is when the connection to a server is slow.
(0032903)
advil (administrator)
2019-01-06 19:55
edited on: 2019-01-06 19:58

There may be multiple bugs here, but I'm expanding this report to also include cases where the player's icon doesn't get erased during autotravel, as in https://i.redd.it/l2obqx77eq821.png [^] , https://www.reddit.com/r/dcss/comments/ad2ct7/dae_have_this_problem_even_items_get_frozen_in/ [^] . I have been able to reproduce this online on some servers (CBRO/CUE) by setting `travel_delay` to a positive number (e.g. 1) and using chrome (not firefox/safari). On CBRO this seems to be independent of game version (well, I went back only to 0.18), even though reports only started recently, so I suspect it involves the server, rather than the client. The bug that shows up with autotravel is independent of lag or connection quality. It shows up for spectators too, as long as they are using chrome (regardless of what browser the player is using).

I've also been able to reproduce it locally with similar settings + chrome, with the caveat that for me (OS X) it doesn't show up on a debug or even a debug-lite build. But with e.g. just `make WEBTILES=y` it's easy to reproduce.

(0033062)
ebering (developer)
2019-02-07 23:33

It seems that this was resolved successfully by 0.23-a0-654-g63bca24c07. Please re-open this bug if the problem returns.

- Issue History
Date Modified Username Field Change
2018-12-06 07:02 RoGGa New Issue
2018-12-31 13:38 jejorda2 Note Added: 0032892
2019-01-02 02:20 RoGGa Note Added: 0032895
2019-01-06 19:55 advil Note Added: 0032903
2019-01-06 19:55 advil Status new => confirmed
2019-01-06 19:58 advil Note Edited: 0032903
2019-01-06 20:05 advil Summary enemy or Hep ancestor icon is not erased => enemy or Hep ancestor icon is not erased (also, player icon during autotravel)
2019-01-10 19:23 ebering Relationship added related to 0011283
2019-01-12 17:52 ebering Relationship added related to 0011776
2019-01-12 18:22 ebering Relationship added related to 0011762
2019-02-07 23:33 ebering Note Added: 0033062
2019-02-07 23:33 ebering Status confirmed => resolved
2019-02-07 23:33 ebering Fixed in Branch => 0.24 development branch
2019-02-07 23:33 ebering Resolution open => done
2019-02-07 23:33 ebering Assigned To => ebering
2019-02-08 18:58 RoGGa Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker