Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011776 [DCSS] Bug Report minor sometimes 2018-12-04 00:20 2019-02-07 23:37
Reporter ThreeInvisibleDucks View Status public  
Assigned To ebering
Priority normal Resolution done  
Status resolved   Product Branch 0.23 stable branch
Summary 0011776: Webtiles UI sometimes bugs and doesn't show the current situation
Description Sometimes the UI bugs and doesn't show the current situation. I've been trying to find out whether it's my particular setup or if someone else has encountered it. I've now heard that it's just not me, so after trying different browsers, disabling extensions, playing on different sites I've decided to report it as a bug.

I've most often encountered the bug of the screen not refreshing properly when I have been playing on https://underhound.eu:8080. [^] It has also triggered for me when playing on http://crawl.xtahua.com:8080, [^] but it seems to trigger less often.

The worst version of the bug I've encountered is when I go down/up the stairs, the monsters are updated, but the terrain isn't. So I can see the monsters, but the terrain remains black.

The other version is that when someone joins my game as a spectator, I can still see the terrain, but the monsters are perhaps not where the game shows them to be, and sometimes I can see a monster being there but it's not.

The people coming into the spectator chat seems to trigger the bug for me very reliably, especially on UEU.

Because I have not heard from other people that they have not encountered this bug, after exhausting the options of disabling all the browser extensions and trying multiple servers, I've come into the conclusion that it is a real bug.

Also, my crawlrc file has a lot of "force_more_message" warnings that I have suspected might be a trigger, so it could be that people not having those might not encounter it as often or not at all.

Additional Information
Tags No tags attached.
Attached Files txt file icon crawlrc.txt [^] (24,885 bytes) 2018-12-04 00:44 [Show Content]
gz file icon 513.gz [^] (9,974 bytes) 2018-12-04 13:52

- Relationships
related to 0011780closedebering enemy or Hep ancestor icon is not erased (also, player icon during autotravel) 

-  Notes
(0032832)
ThreeInvisibleDucks (reporter)
2018-12-04 00:45

I added my crawlrc with the force-more-messages I mentioned about in my original report.
(0032833)
ThreeInvisibleDucks (reporter)
2018-12-04 00:48

The latest version of Chromium I've noticed the bug with:

Version 70.0.3538.77 (Official Build) Built on Ubuntu , running on Ubuntu 18.04 (64-bit)
(0032834)
ThreeInvisibleDucks (reporter)
2018-12-04 00:49

I'm also playing on Ubuntu 18.04 LTS updated at least weekly
(0032835)
ThreeInvisibleDucks (reporter)
2018-12-04 01:02

The Firefox version the bug is for me reproducable with: 63.0.3 (64-bit)
(0032921)
ebering (developer)
2019-01-12 17:52

I suspect this is related to 11780, which was a chrome issue with how webtiles was reacting to our of order messages. A tentative fix for that bug has been applied, please report back if the problem persists.
(0033064)
ebering (developer)
2019-02-07 23:36

It seems that this was resolved successfully by 0.23-a0-654-g63bca24c07. Please re-open this bug if the problem returns.

- Issue History
Date Modified Username Field Change
2018-12-04 00:20 ThreeInvisibleDucks New Issue
2018-12-04 00:44 ThreeInvisibleDucks File Added: crawlrc.txt
2018-12-04 00:45 ThreeInvisibleDucks Note Added: 0032832
2018-12-04 00:48 ThreeInvisibleDucks Note Added: 0032833
2018-12-04 00:49 ThreeInvisibleDucks Note Added: 0032834
2018-12-04 01:02 ThreeInvisibleDucks Note Added: 0032835
2018-12-04 13:52 markus34 File Added: 513.gz
2018-12-17 12:51 markus34 Note Added: 0032857
2019-01-12 17:52 ebering Note Added: 0032921
2019-01-12 17:52 ebering Relationship added related to 0011780
2019-02-07 23:36 ebering Note Added: 0033064
2019-02-07 23:36 ebering Status new => resolved
2019-02-07 23:36 ebering Fixed in Branch => 0.24 development branch
2019-02-07 23:36 ebering Resolution open => done
2019-02-07 23:36 ebering Assigned To => ebering
2019-02-07 23:38 ebering Note Deleted: 0032857


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker