Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011747 [DCSS] Bug Report minor have not tried 2018-11-04 02:39 2018-11-14 09:51
Reporter aperiodic View Status public  
Assigned To gammafunk
Priority normal Resolution done  
Status resolved   Product Branch experimental branch
Summary 0011747: Weapon types are not always identified
Description Pikel had a "glowing whip", which changed to an unidentified "whip of flaming" after he attacked me.
Possibly related, I see a "runed dire flail" in a ghost vault.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0032763)
NormalPerson7 (reporter)
2018-11-04 09:29

Weapons on the ground are not automatically identified, so that explains the runed dire flail. Pikel's issue is a bug, though.
(0032764)
aperiodic (reporter)
2018-11-04 14:33

I forgot to mention that the runed dire flail was a dancing weapon.
(0032796)
gammafunk (administrator)
2018-11-14 09:51

Pike's initial lack of proper identification may have been due to when you first saw him, if it was behind glass. This was fixed in 0.23-a0-420-g8c0b414. In any case, when testing in trunk, Pikel's weapon properly identifies upon sight with being fully identified after he dies as well.

The issue with the runed dire flail is definitely fixed in 0.23-a0-420-g8c0b414, since it was behind glass in the ghost vault. Further dancing weapon display and messaging issues were fixed in 0.23-a0-421-g923571c and 0.23-a0-422-g30b1108.

All issues in this report should be fixed, but feel free to reopen this bug if you observe any of them again in the latest trunk version.

- Issue History
Date Modified Username Field Change
2018-11-04 02:39 aperiodic New Issue
2018-11-04 09:29 NormalPerson7 Note Added: 0032763
2018-11-04 14:33 aperiodic Note Added: 0032764
2018-11-04 14:33 aperiodic Note Added: 0032765
2018-11-04 14:33 aperiodic Note Added: 0032766
2018-11-04 14:33 aperiodic Note Added: 0032767
2018-11-04 14:34 aperiodic Note Deleted: 0032765
2018-11-04 14:34 aperiodic Note Deleted: 0032766
2018-11-04 14:34 aperiodic Note Deleted: 0032767
2018-11-14 09:51 gammafunk Note Added: 0032796
2018-11-14 09:51 gammafunk Status new => resolved
2018-11-14 09:51 gammafunk Resolution open => done
2018-11-14 09:51 gammafunk Assigned To => gammafunk


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker