Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011710 [DCSS] Bug Report minor always 2018-10-14 08:05 2018-10-14 22:58
Reporter TruePurple View Status public  
Assigned To
Priority normal Resolution no change required  
Status closed   Product Branch 0.22 stable branch
Summary 0011710: Autorest not working right.
Description See how it refuses to let me autorest with a sleeping orc nearby. https://postimg.cc/CZ6WpS71 [^] Ebering swears it doesn't work like this. If I go one tile up so that I can not actively see the sleeping orc, it allows me to autorest. Also seeing a enemy through transparent walls that can't get you also disables autorest.

I think any time you can see a enemy, autorest disables itself. It doesn't matter if they are sleeping, through a transparent wall or nonswimmers surrounded by deep water.
Additional Information
Tags No tags attached.
Attached Files png file icon Orc is nearby!.png [^] (646,915 bytes) 2018-10-14 08:05

- Relationships

-  Notes
(0032685)
ebering (developer)
2018-10-14 14:57

This orc could be a danger to your character. Disabling auto-rest in this situation is intentional.
(0032686)
TruePurple (reporter)
2018-10-14 22:54
edited on: 2018-10-14 22:56

You said sleeping foes doesn't trigger it. And the fact is that it would never wake if I never moved/acted. It could be a sleeping goblin surrounded by transparent walls surrounded by deep water, and I'm level 20, if it's within my vision, it disables autosleep.

 Maybe we could have a slightly less absurdly conservative version of autosleep as a additional alternative to one that refuses to work if any enemies at all are in view? The alternative is just to press period over and over and over, or lean on it and that's way more risky.

(0032687)
ebering (developer)
2018-10-14 22:57

If you took that as my meaning then you misunderstood. Sleeping foes always prevent resting.

Your description of the behavior of sleeping foes is factually incorrect. Each turn you are in sight of a sleeping foe it gets a stealth check against you and if you fail it it will wake up and notice you, even if you never acted.

If a monster is totally surrounded by transparent walls (as in ghost vaults) auto rest will ignore that monster and rest. Please do not re-open this issue it is not a bug.

- Issue History
Date Modified Username Field Change
2018-10-14 08:05 TruePurple New Issue
2018-10-14 08:05 TruePurple File Added: Orc is nearby!.png
2018-10-14 14:57 ebering Note Added: 0032685
2018-10-14 14:57 ebering Status new => closed
2018-10-14 14:57 ebering Resolution open => no change required
2018-10-14 22:54 TruePurple Note Added: 0032686
2018-10-14 22:54 TruePurple Status closed => new
2018-10-14 22:54 TruePurple Resolution no change required => reopened
2018-10-14 22:56 TruePurple Note Edited: 0032686
2018-10-14 22:57 ebering Note Added: 0032687
2018-10-14 22:58 ebering Status new => closed
2018-10-14 22:58 ebering Resolution reopened => no change required


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker