Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011704 [DCSS] Bug Report minor always 2018-10-11 11:13 2019-02-02 10:08
Reporter kitchen_ace View Status public  
Assigned To ebering
Priority normal Resolution done  
Status closed   Product Branch 0.22 old branch
Summary 0011704: Resting near "safe" enemies doesn't take into account polearms, maybe other weapons too
Description There's a Bailey where there's a large moat with a lot of polearm wielding orcs that you have to navigate around. In my current game (EthnicCake on CJR, FeFE) I was resting near there only to have my rest stopped by an orc attacking me, one that was not on screen when I started resting. I assume this is because the orc, normally a melee enemy, was behind the water and so the game though I was safe from him.

I know some enemies have ranged weapons/wands/etc. that are hidden until they use them, but in the case of the polearm, it was obvious that it could reach me, and so I would expect resting to stop when it entered my LOS. Alternately I could see it make sense for resting to stop when an enemy enters your LOS that was not there before, regardless of whether or not it can reach you.
Additional Information
Tags No tags attached.
Attached Files

- Relationships
related to 0011782new i_feel_safe despite having monsters in view 

-  Notes
(0033034)
ebering (developer)
2019-02-02 06:09

Fixed in 0.24-a0-30-g0f9db6f4df

- Issue History
Date Modified Username Field Change
2018-10-11 11:13 kitchen_ace New Issue
2019-01-24 01:56 ebering Relationship added related to 0011782
2019-02-02 06:09 ebering Note Added: 0033034
2019-02-02 06:09 ebering Status new => resolved
2019-02-02 06:09 ebering Resolution open => done
2019-02-02 06:09 ebering Assigned To => ebering
2019-02-02 10:07 kitchen_ace Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker