Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011691 [DCSS] Patches tweak N/A 2018-09-23 09:39 2018-09-23 10:01
Reporter collin38 View Status public  
Assigned To aidanholm
Priority normal Resolution done  
Status resolved   Product Branch longterm development (0.25+)
Summary 0011691: Prevent spectators with hidden chat from counting in total.
Description When a spectator has hidden their chat with "/hide (forever)", They are removed from the spectators list, but they still contribute to the number of spectators. This is confusing; if a user isn't in the list, they shouldn't be in the total count. I've attached a screenshot which shows 2 spectators but only lists 1 (beem)

This has the intended side effect of allowing users to spectate without disturbing the player. For example, I was asked "plz DONT SPEC ME." For such users it would be nice if there was a way to watch without interrupting.
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Prevent-spectators-with-chat-hidden-from-counting-in.patch [^] (987 bytes) 2018-09-23 09:39 [Show Content]
png file icon invis_spectator.PNG [^] (3,806 bytes) 2018-09-23 09:41

- Relationships

-  Notes
(0032643)
aidanholm (developer)
2018-09-23 10:00

Thanks for reporting! Fixed at dcd3064b9151.

- Issue History
Date Modified Username Field Change
2018-09-23 09:39 collin38 New Issue
2018-09-23 09:39 collin38 File Added: 0001-Prevent-spectators-with-chat-hidden-from-counting-in.patch
2018-09-23 09:41 collin38 File Added: invis_spectator.PNG
2018-09-23 09:41 collin38 Issue Monitored: collin38
2018-09-23 10:00 aidanholm Note Added: 0032643
2018-09-23 10:00 aidanholm Status new => resolved
2018-09-23 10:00 aidanholm Fixed in Branch => longterm development (0.23+)
2018-09-23 10:00 aidanholm Resolution open => done
2018-09-23 10:00 aidanholm Assigned To => aidanholm


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker