Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011678 [DCSS] Bug Report trivial have not tried 2018-09-16 07:24 2018-09-17 14:19
Reporter RoGGa View Status public  
Assigned To aidanholm
Priority normal Resolution done  
Status resolved   Product Branch longterm development (0.23+)
Summary 0011678: alignment of Shop listings on Ctrl-o screen
Description found 2 trivial misalignments in the same game
see the 2 screen capture
Additional Information
Tags No tags attached.
Attached Files png file icon Shop listing on Ctrl-o.png [^] (53,559 bytes) 2018-09-16 07:24


png file icon Shop listing on Ctrl-o #2.png [^] (72,218 bytes) 2018-09-16 07:26

- Relationships

-  Notes
(0032635)
aidanholm (developer)
2018-09-17 08:08

Any chance you could upload the save? I can't immediately reproduce this myself.
(0032636)
RoGGa (reporter)
2018-09-17 09:20

sorry TroHun is no more! I only have the morgue if that can help with the shops listed as:

Shops:
D:6 [ D:8 * D:15 ? Orc:1 ( Orc:2 *:=( Elf:3 : Snake:3 =}=( Snake:4 [%(?( Vaults:1 :?!?[
Vaults:2 } Vaults:3 = Vaults:5 *

Keep in mind this was with WinTiles v0.23-a0-8, which is from a few days before the tournament started (about 45 days ago). You've done many commits since so I wouldn't be surprised if it has been fixed already.

I just downloaded v0.22.1 and will play with that for a week.
I'll keep an eye out to see if it happens in that version.

(Also, if newer trunk offline versions are not available by Sept 24th, I'll try to compile myself for Windows during that weekend. )
(0032637)
aidanholm (developer)
2018-09-17 14:18

I believe this was fixed as a side effect of 19e28b46, the intent of which was to wrap chardumps to a more reasonable width. Previously, the overview screen used get_number_of_cols() to determine the wrapping width, rather than the width of the overview popup; currently it uses a hardcoded value of 79, which, while still not ideal, is almost equal to the overview screen's hardcoded width of 80.

Thanks for reporting :)

- Issue History
Date Modified Username Field Change
2018-09-16 07:24 RoGGa New Issue
2018-09-16 07:24 RoGGa File Added: Shop listing on Ctrl-o.png
2018-09-16 07:26 RoGGa File Added: Shop listing on Ctrl-o #2.png
2018-09-17 08:08 aidanholm Note Added: 0032635
2018-09-17 09:20 RoGGa Note Added: 0032636
2018-09-17 14:18 aidanholm Note Added: 0032637
2018-09-17 14:18 aidanholm Status new => resolved
2018-09-17 14:18 aidanholm Fixed in Branch => longterm development (0.23+)
2018-09-17 14:18 aidanholm Resolution open => done
2018-09-17 14:18 aidanholm Assigned To => aidanholm


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker