Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011666 [DCSS] Bug Report tweak always 2018-09-05 15:02 2018-09-25 13:49
Reporter hayenne View Status public  
Assigned To aidanholm
Priority normal Resolution done  
Status closed   Product Branch longterm development (0.25+)
Summary 0011666: Aimed spells consume MP when not cast
Description There are two scenarios when this happens:

1. Cast a spell with 'Z', then cancel aiming.

2.
- Cast a spell with 'z', aim it in such a way that it might hurt you.
- "That beam is likely to hit you. Continue anyway?" confirmation appears. Press Esc or N.

In both scenarios MP is consumed despite the spell being not cast.

Additional Information
Tags No tags attached.
Attached Files

- Relationships
duplicate of 0011598closedaidanholm MP display doesn't get reset on canceling spell casting. 

-  Notes
(0032612)
Yermak (reporter)
2018-09-05 15:32
edited on: 2018-09-05 15:34

MP isn't consumed, it doesn't get refreshed back. But this is still a bug: duplicate of 0011598

(0032629)
aidanholm (developer)
2018-09-15 14:37

Thanks for reporting! Fixed at d05d27e280a2
(0032651)
hayenne (reporter)
2018-09-25 13:49

Verified in trunk.

- Issue History
Date Modified Username Field Change
2018-09-05 15:02 hayenne New Issue
2018-09-05 15:32 Yermak Note Added: 0032612
2018-09-05 15:34 Yermak Note Edited: 0032612
2018-09-15 14:04 aidanholm Relationship added duplicate of 0011598
2018-09-15 14:37 aidanholm Note Added: 0032629
2018-09-15 14:37 aidanholm Status new => resolved
2018-09-15 14:37 aidanholm Fixed in Branch => longterm development (0.23+)
2018-09-15 14:37 aidanholm Resolution open => done
2018-09-15 14:37 aidanholm Assigned To => aidanholm
2018-09-25 13:49 hayenne Note Added: 0032651
2018-09-25 13:49 hayenne Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker