Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011657 [DCSS] Bug Report minor have not tried 2018-08-30 05:56 2019-03-06 07:00
Reporter Yermak View Status public  
Assigned To advil
Priority normal Resolution done  
Status closed   Product Branch longterm development (0.25+)
Summary 0011657: Positive travel_delay screws Firefox spectators.
Description I haven't tried other browsers, but here is the deal with Firefox:
if you start watching player who doesn't have travel_delay set to -1, then ctrl-tab to another tab, spend there some time and come back, browser will start playing back all the movement player has done during your absence (and by movement I mean only autoexplore moves, the other stuff is skipped). If the absence was long, it's simpler to refresh the tab, losing current conversation.
What's interesting, if you alt-tab into another application, this won't happen.
If travel_delay = -1, this won't happen.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0032658)
NormalPerson7 (reporter)
2018-09-29 18:27

This is the case for all browsers. Animation replay always happens for all animations and always has happened. Having said that, I agree it's annoying and probably slows the server down somewhat as well to replay all those animations in quick succession.
(0033134)
advil (administrator)
2019-02-27 23:08

This should be fixed as of https://github.com/crawl/crawl/commit/a036e810d7e9 [^] and https://github.com/crawl/crawl/commit/42e81859b23d [^] ; I just forgot to come back and close this bug.

This was all actually happening client-side, and was due to how browsers handle delays in completely non-visible windows.

- Issue History
Date Modified Username Field Change
2018-08-30 05:56 Yermak New Issue
2018-09-29 18:27 NormalPerson7 Note Added: 0032658
2019-01-10 19:20 ebering Relationship added related to 0011283
2019-01-10 19:21 ebering Relationship deleted related to 0011283
2019-02-27 23:08 advil Note Added: 0033134
2019-02-27 23:08 advil Status new => resolved
2019-02-27 23:08 advil Fixed in Branch => 0.23 stable branch
2019-02-27 23:08 advil Resolution open => done
2019-02-27 23:08 advil Assigned To => advil
2019-03-06 06:59 Yermak Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker