Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011643 [DCSS] Bug Report trivial always 2018-08-27 10:35 2018-08-28 22:18
Reporter TAS2012 View Status public  
Assigned To
Priority normal Resolution reopened  
Status new   Product Branch longterm development (0.24+)
Summary 0011643: scrolling page by page in item lists no longer wraps
Description It used to be that when page by page scrolling in item lists (e.g. inventory, Ctrl+F results) with Space, after reaching the last page pressing Space one more time took you back to the first page.
In recent versions, sometimes during 0.22 development I think, this does not work anymore, nothing happens when pressing Space on the last page.

Unless this is somehow intended, I ask to please restore the earlier functionality.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0032589)
aidanholm (developer)
2018-08-27 14:15

This was an intentional change, implemented at https://github.com/crawl/crawl/commit/64c3ba73d400. [^] While I appreciate that this change may take some getting used to, for the reasons outlined in that commit message, I don't think that menu wrapping is going to be re-added any time soon.
(0032596)
TAS2012 (reporter)
2018-08-28 21:52
edited on: 2018-08-28 21:54

Sorry for reopening this, but I couldn't see how to write a note otherwise. :(

I see the reasoning in the commit note, but I find it quite an additional hassle the the new way.

It might be that I have to adjust my habits, but currently I find myself going page by page down to the end to see the whole list (as before), and then going all the way back up again (page by page) to perform my actions on list items on early pages.

The commit message talks about making it opt-in rather than opt-out. As far as I can understand, this is not an opt-in for the end user? Would it be possible to have an opt-in for the old functionality?

(0032597)
RoGGa (reporter)
2018-08-28 22:16

Isn't that what [Home] and [End] keys are for?
(0032598)
TAS2012 (reporter)
2018-08-28 22:18

Good idea, undocumented but already tried that anyway. Sadly neither of them does anything for me (but PgUp and PgDn does what is expected).

- Issue History
Date Modified Username Field Change
2018-08-27 10:35 TAS2012 New Issue
2018-08-27 14:15 aidanholm Note Added: 0032589
2018-08-27 14:15 aidanholm Status new => closed
2018-08-27 14:16 aidanholm Resolution open => won't do
2018-08-28 21:52 TAS2012 Note Added: 0032596
2018-08-28 21:52 TAS2012 Status closed => new
2018-08-28 21:52 TAS2012 Resolution won't do => reopened
2018-08-28 21:54 TAS2012 Note Edited: 0032596
2018-08-28 22:16 RoGGa Note Added: 0032597
2018-08-28 22:18 TAS2012 Note Added: 0032598


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker