Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011642 [DCSS] Bug Report minor always 2018-08-26 23:26 2018-08-27 15:12
Reporter RoGGa View Status public  
Assigned To aidanholm
Priority normal Resolution done  
Status resolved   Product Branch longterm development (0.25+)
Summary 0011642: two mini-map issues on local Tiles (Win10 laptop 1366x768)
Description 1st issue:

With the following in my init.txt file:

#tile_full_screen = false
tile_map_pixels = 5
tile_layout_priority = minimap, inventory

I have come across an instance of a mini-map not showing completely in full-screen mode. This is usually not an issue except for the rare occasion with first and last line/row of pixels missing.

(see first attachment. It is not in full-screen mode but I was able to replicate the issue by making the window longer in height than the screen.)

The 2nd issue detailed in a separate Note.
Additional Information
Tags No tags attached.
Attached Files png file icon mini-map not showing completely with tile_map_pixels = 5.png [^] (195,362 bytes) 2018-08-26 23:26
png file icon mini-map not showing at all with tile_map_pixels = 5.png [^] (168,374 bytes) 2018-08-26 23:32

- Relationships

-  Notes
(0032586)
RoGGa (reporter)
2018-08-26 23:31

The 2nd issue is relate to trying to do a screen capture with the following in my init.txt:

tile_full_screen = false
tile_map_pixels = 5
tile_layout_priority = minimap, inventory

In the 2nd attachment, you can see that the minimap does not show at all!
(0032587)
RoGGa (reporter)
2018-08-26 23:47

I obviously could comment out the line:

#tile_map_pixels = 5

so that it returns to its default, but I then find the minimap too small to click on.

From my perspective, the first issue is not a big one...but the 2nd one is just bizarre...and it is the reason for this bug report since it states in the file: options_guide.txt

"tile_layout_priority = minimap, inventory, command, spell, monster
        (Ordered list option)
        This option allows you to control the order in which elements are
        placed on the right of the screen, below the stat area. On small
        resolution, there won't be enough room for everything, so only the
        first items will be placed.
...
        The minimap is always placed
        between the stat area and the tabs. The memorisation and skill tabs can
        be added to the list too, but are not by default."
(0032590)
aidanholm (developer)
2018-08-27 15:12

Thanks for reporting! Both of these are now fixed in trunk. The minimap required size is now correctly calculated, which fixes issue 1, and setting tile_map_pixels no longer prevents the minimap from shrinking (it's now a maximum size, as specified in the options guide).

- Issue History
Date Modified Username Field Change
2018-08-26 23:26 RoGGa New Issue
2018-08-26 23:26 RoGGa File Added: mini-map not showing completely with tile_map_pixels = 5.png
2018-08-26 23:31 RoGGa Note Added: 0032586
2018-08-26 23:32 RoGGa File Added: mini-map not showing at all with tile_map_pixels = 5.png
2018-08-26 23:47 RoGGa Note Added: 0032587
2018-08-27 15:12 aidanholm Note Added: 0032590
2018-08-27 15:12 aidanholm Status new => resolved
2018-08-27 15:12 aidanholm Fixed in Branch => longterm development (0.23+)
2018-08-27 15:12 aidanholm Resolution open => done
2018-08-27 15:12 aidanholm Assigned To => aidanholm


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker