Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011629 [DCSS] Bug Report minor have not tried 2018-08-20 04:50 2018-08-25 19:17
Reporter silenth View Status public  
Assigned To aidanholm
Priority normal Resolution done  
Status resolved   Product Branch 0.22 old branch
Summary 0011629: Cycling through downstairs after using ?MagicMapping with X> goes to unseen portals but not shops
Description When reading the scroll of magic mapping, portals and shops are treated as equivalent and are not revealed. The bug is that, after reading magic mapping, using X to look around the level map and > to cycle through portals will take the cursor to all unseen downstairs as well as unseen portals (noticed on a Wizlab portal in Vaults) but not to unseen shops, even though they are meant to be ambiguously identified with the same icon by the scroll. Players can thus determine which icons are portals and which are shops by process of elimination, which contradicts the intended functionality of them being ambiguous.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0032566)
silenth (reporter)
2018-08-20 04:52

Forgot to add, was playing Webtiles on CAO v0.22 tournament build.
(0032572)
aidanholm (developer)
2018-08-25 19:16

Thanks! This has been fixed at https://github.com/crawl/crawl/commit/b1aafca977ad; [^] portals entrances/exits should now be cycled through only if they are already known to be portals.

- Issue History
Date Modified Username Field Change
2018-08-20 04:50 silenth New Issue
2018-08-20 04:52 silenth Note Added: 0032566
2018-08-25 19:16 aidanholm Note Added: 0032572
2018-08-25 19:16 aidanholm Status new => resolved
2018-08-25 19:16 aidanholm Fixed in Branch => longterm development (0.23+)
2018-08-25 19:16 aidanholm Resolution open => done
2018-08-25 19:16 aidanholm Assigned To => aidanholm


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker