Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011584 [DCSS] Bug Report major have not tried 2018-08-05 14:07 2018-09-30 00:41
Reporter stoneychips View Status public  
Assigned To aidanholm
Priority normal Resolution done  
Status resolved   Product Branch 0.22 development branch
Summary 0011584: Evocables in Beta malfunction in targeting beam
Description This is the 0.22 (beta) Tiles server, CPO, Win10, Chrome.

I used e(v)oke Wand of Enslavement, first targeting a mob at position 9 (up and to the right). I found that at least after that, it's possible to move the targeting box around using horizontal aiming (4,6 keypad or right and left arrow keys). The other keypad number directions (except 5) do not work, nor do the up and down arrows.

This appears somehow the inverse of the evocables targeting bug in current 0.23 Trunk, where I have reported being able to target horizontally but no other directions! May we have aim in all directions in both versions please. ;)
Additional Information
Tags evoke, webtiles
Attached Files jpg file icon targetissues.jpg [^] (39,173 bytes) 2018-08-06 08:53

- Relationships
related to 0011579new Evocables fail to target anything that is not horizontal 
related to 0011592resolvedadvil Up and Down Arrow Keys not working on item search cursor 

-  Notes
(0032504)
stoneychips (reporter)
2018-08-05 14:09
edited on: 2018-08-05 14:11

For comparison: The previously reported bug in 0.23 Trunk is 0011579.

(0032506)
stoneychips (reporter)
2018-08-05 14:21

I was trying to reconfirm that I saw what I saw, and in the process I ended up using the wand to charm an ogre standing at position 9 (up to the right). That actually happened because I pushed 5 to try all the keypad numbers, while the box was still sitting on the ogre. (Is this clear? I'm quite certain it did not work in many positions where you should be able to target, and with most of the arrows and numbers each time, and that I did get the ogre charmed.)

After charming the ogre, now the wand will target horizontally - but not in other directions! Okay, please consider this Major if that's appropriate.
(0032508)
advil (developer)
2018-08-06 05:13

If you can reproduce this again, can you look at the web console for your browser (e.g. firefox tools -> web developer -> web console) and see if there are any errors?
(0032509)
stoneychips (reporter)
2018-08-06 08:51

Upgraded Firefox to 61.0.2. The bug had persisted in 61.0.2. It somehow went away briefly after firing the wand at position 6, but returned after firing it again the next turn. I keep accidentally opening the wrong browser or closing this window and losing logs though, oops. Not used to multiple windows with this.

Finished the fight (escape) in Chrome, seeing no errors logged in that console. Returning to Firefox with a new fight: I am able to target the orc shown or horizontally along rows, but not for example the two squares above me that the beam passes through to reach the orc.

Current error log before I do anything else silly:

Bootstrapped manifest not allowed to use 'resource' directive. chrome.manifest:1
Bootstrapped manifest not allowed to use 'resource' directive. chrome.manifest:7
Bootstrapped manifest not allowed to use 'resource' directive. chrome.manifest:2
1533537809007 addons.webextension.helper-sig@savefrom.net WARN Please specify whether you want browser_style or not in your browser_action options.
1533537809007 addons.webextension.{4ED1F68A-5463-4931-9384-8FFF5ED91D92} WARN Please specify whether you want browser_style or not in your browser_action options.
[Show/hide message details.] Unchecked lastError value: Error: Could not establish connection. Receiving end does not exist.
mcafee_wa_bkground.js:106
[Show/hide message details.] Unchecked lastError value: Error: Could not establish connection. Receiving end does not exist.
mcafee_wa_bkground.js:102
[Show/hide message details.] Unchecked lastError value: Error: Could not establish connection. Receiving end does not exist.
mcafee_wa_bkground.js:103
Key event not available on some keyboard layouts: key=“i” modifiers=“accel,alt,shift” id=“key_browserToolbox” browser.xul
XrayWrapper denied access to property "isAvailable" (reason: value is callable). See https://developer.mozilla.org/en-US/docs/Xray_vision [^] for more information. Note that only the first denied property access from a given global object will be reported. ExtensionContent.jsm:893:6
XrayWrapper denied access to property "isAvailable" (reason: value is callable). See https://developer.mozilla.org/en-US/docs/Xray_vision [^] for more information. Note that only the first denied property access from a given global object will be reported. ExtensionUtils.jsm:546:50
Use of mozImageSmoothingEnabled is deprecated. Please use the unprefixed imageSmoothingEnabled property instead. cell_renderer.js:1046:16
XML Parsing Error: no root element found
Location: https://ff-input.mxpnl.net/data?_channel_id=&_partner_id=39571&_sub_id=0000&_app_version=1.0.23&_app=cs-dca [^]
Line Number 1, Column 1:
(0032510)
stoneychips (reporter)
2018-08-06 08:57

I should say, it chooses the orc marked as the automatic first choice target, and I'm able to move the box horizontally along the same row. That's all.
(0032523)
advil (developer)
2018-08-09 03:06

ok, thanks, that didn't tell me what I hoped, but that's ok. Can you confirm if this is specific to arrow/numpad keys, or does it apply to vi keys (hjkl) as well? Also (optimistically) is it still happening in the beta? I just fixed a somewhat complicated bug in targeting mode that could impact this, though I haven't specifically been able to replicate this particular bug (or the other targeting bug in trunk versions).
(0032524)
stoneychips (reporter)
2018-08-09 10:29

It's still bugged in both Trunk and Beta.

It does not affect the alpha keys in either though, so I suppose I'll have to try to get used to those ("finally get a character with over 10 slay," ha)

Console again: Opened it again in both betas and all I see after logging into Beta actually (when looking at the Firefox one), is the line about MozImageSmoothingEnabled being deprecated.

Now Firefox console upon logging out of Beta and logging into Trunk:
Public-Key-Pins: The certificate used by the site was not issued by a certificate in the default root certificate store. To prevent accidental breakage, the specified header was ignored.[Learn More] v1
Public-Key-Pins: The certificate used by the site was not issued by a certificate in the default root certificate store. To prevent accidental breakage, the specified header was ignored.[Learn More] classify_client
Public-Key-Pins: The certificate used by the site was not issued by a certificate in the default root certificate store. To prevent accidental breakage, the specified header was ignored.[Learn More] signed
Public-Key-Pins: The certificate used by the site was not issued by a certificate in the default root certificate store. To prevent accidental breakage, the specified header was ignored.[Learn More] signed
Websocket connection was closed 1001 app.min.js:40:25076
XML Parsing Error: no root element found
Location: https://ff-input.mxpnl.net/data?_channel_id=&_partner_id=39571&_sub_id=0000&_app_version=1.0.23&_app=cs-dca [^]
Line Number 1, Column 1: data:1:1
Use of mozImageSmoothingEnabled is deprecated. Please use the unprefixed imageSmoothingEnabled property instead. cell_renderer.js:1046:16
1533802697262 addons.xpi-utils WARN disabling legacy extension {19503e42-ca3c-4c27-b1e2-9cdb2170ee34}

Hmm. Still in Trunk, went to inventory and e(v)oke wand, trying the arrows and keypad again. That last warning about legacy extension is repeated once, then there are multiple (8) instances of this type.

1533802819548 addons.update-checker WARN onUpdateCheckComplete failed to parse update manifest: [Exception... "Update manifest is missing a required addons property." nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: resource://gre/modules/addons/AddonUpdateChecker.jsm [^] :: getRequiredProperty :: line 120" data: no] Stack trace: getRequiredProperty()@resource://gre/modules/addons/AddonUpdateChecker.jsm:120 [^]
parseJSONManifest()@resource://gre/modules/addons/AddonUpdateChecker.jsm:130 [^]
onLoad()@resource://gre/modules/addons/AddonUpdateChecker.jsm:309 [^]
UpdateParser/<()@resource://gre/modules/addons/AddonUpdateChecker.jsm:241 [^]

All that is followed by:

1533802820036 addons.update-checker WARN Request failed: https://download.sf-helper.com/mozilla/updates.json [^] - [Exception... "Certificate issuer is not built-in." nsresult: "0x80004004 (NS_ERROR_ABORT)" location: "JS frame :: resource://gre/modules/CertUtils.jsm [^] :: checkCert :: line 167" data: no]
This site appears to use a scroll-linked positioning effect. This may not work well with asynchronous panning; see https://developer.mozilla.org/docs/Mozilla/Performance/ScrollLinkedEffects [^] for further details and to join the discussion on related tools and features! dcss-web-trunk
(0032529)
advil (developer)
2018-08-09 16:02

Do you have anything in your rc file that might be relevant? (I checked under what I think your player name is on CPO and couldn't find anything though.) What kind of keyboard do you have? Do you know if this is specific to one computer, or happens for you on other computers besides your main one?
(0032532)
advil (developer)
2018-08-09 17:35

I have (finally) replicated a version of this but it only happens for me when evoking from inventory, not when evoking from the main screen; is this what is happening for you?
(0032533)
stoneychips (reporter)
2018-08-09 17:52

Omg. I've always been doing it from inventory! Now I feel silly, but that's just the way I found to get to it when I started (probably because the inventory tells you) and I never got used to many of the more direct keyboard shortcuts. So back to "minor" with this for me. It's easy enough to just push v without going into inventory. Thanks for looking at this so much.

As far as the other details: I play as loopi on CPO. I haven't added anything to rc at all, except the team from the last tourney is still in the Trunk one. I have been using this same external USB keyboard (a Kensington flat) for over two years now. But it's the same situation with the keyboard on the Asus ROG laptop it's attached to.

I don't have another machine right handy - maybe if I found a net cafe somewhere. I do have an Android tablet that can play the Online version, but I don't know how different the code is that runs that.
(0032534)
stoneychips (reporter)
2018-08-09 17:59

Fwiw in Android online: There's no problem with using the arrow keys to target on either version.
(0032535)
advil (developer)
2018-08-09 18:25

I think I have fixed this in https://github.com/crawl/crawl/commit/dab52ba086e2beb46e44eb2b469f34f4f774b20e [^] , figuring out that it was from the inventory was the key :). CPO should update relatively soon, at least for trunk (not sure what the beta update timing is there).
(0032538)
stoneychips (reporter)
2018-08-09 19:24

I do see it fixed in Trunk! Whee! :) :)

I don't see the fix in Beta yet, but this sounds promising. I could probably use more direct shortcuts to speed stuff up too, but maybe being reminded of that is a good thing as well.
(0032542)
stoneychips (reporter)
2018-08-10 17:47

It's fixed on 0.22, yes. Many thanks!
(0032663)
CassieGriffin (reporter)
2018-09-30 00:41

It is bug problem to stop touchpad working. It is also browsing error. If you have any issue with your laptop's touchpad then visit for your solution https://babasupport.org/hp/hp-laptop-touchpad-not-working/ [^]

- Issue History
Date Modified Username Field Change
2018-08-05 14:07 stoneychips New Issue
2018-08-05 14:09 stoneychips Note Added: 0032504
2018-08-05 14:10 stoneychips Note Edited: 0032504
2018-08-05 14:11 stoneychips Note Edited: 0032504
2018-08-05 14:21 stoneychips Note Added: 0032506
2018-08-05 14:22 stoneychips Tag Attached: evoke
2018-08-05 14:22 stoneychips Tag Attached: webtiles
2018-08-06 05:13 advil Note Added: 0032508
2018-08-06 08:51 stoneychips Note Added: 0032509
2018-08-06 08:53 stoneychips File Added: targetissues.jpg
2018-08-06 08:57 stoneychips Note Added: 0032510
2018-08-09 03:06 advil Note Added: 0032523
2018-08-09 10:29 stoneychips Note Added: 0032524
2018-08-09 16:02 advil Note Added: 0032529
2018-08-09 16:03 advil Relationship added related to 0011579
2018-08-09 17:35 advil Note Added: 0032532
2018-08-09 17:36 advil Relationship added related to 0011592
2018-08-09 17:52 stoneychips Note Added: 0032533
2018-08-09 17:59 stoneychips Note Added: 0032534
2018-08-09 18:25 advil Note Added: 0032535
2018-08-09 19:24 stoneychips Note Added: 0032538
2018-08-10 17:47 stoneychips Note Added: 0032542
2018-08-25 18:12 aidanholm Status new => resolved
2018-08-25 18:12 aidanholm Fixed in Branch => longterm development (0.23+)
2018-08-25 18:12 aidanholm Resolution open => done
2018-08-25 18:12 aidanholm Assigned To => aidanholm
2018-09-30 00:41 CassieGriffin Note Added: 0032663


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker