Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011580 [DCSS] Bug Report trivial always 2018-08-02 22:48 2018-08-03 22:17
Reporter NormalPerson7 View Status public  
Assigned To aidanholm
Priority normal Resolution done  
Status resolved   Product Branch 0.22 old branch
Summary 0011580: Asterion's Greater Servant of Makhleb ability uses generic monster spell tile instead of the player ability tile.
Description The player ability Greater Servant of Makhleb that the player gains access to when worshipping Makhleb has a tile. Despite that, on Asterion's x-v screen it uses the generic monster spell tile (the bear paw).

Also, we are very shortly going to need a new 0.23 branch option here on Mantis.
Additional Information
Tags No tags attached.
Attached Files png file icon Elec bolt icon seems wrong.png [^] (52,322 bytes) 2018-08-02 22:56


png file icon 0011580 other monster spell icon missing.png [^] (39,478 bytes) 2018-08-03 22:17

- Relationships

-  Notes
(0032490)
RoGGa (reporter)
2018-08-02 22:55

I noticed that too but kept it aside for a bit since I felt I had too many active bug reports lately.

See attachment for screen capture of Shock Serpent's elec bolt
(0032492)
NormalPerson7 (reporter)
2018-08-03 14:30

Elec bolt is different to lightning bolt, so I understand why that doesn't use the lightning bolt tile, although it's certainly debatable to use the lightning bolt tile.
(0032493)
aidanholm (developer)
2018-08-03 18:22

Thanks; fixed at 40385e1 along with some others.
(0032496)
RoGGa (reporter)
2018-08-03 21:47
edited on: 2018-08-03 21:49

aidan: I did a search for Fire via ?/S and saw other monster spells with the generic paw icon. see attached screen capture.
Edit: ...from 0.23-a0-32

Keep up the great work!!! :D


- Issue History
Date Modified Username Field Change
2018-08-02 22:48 NormalPerson7 New Issue
2018-08-02 22:55 RoGGa Note Added: 0032490
2018-08-02 22:56 RoGGa File Added: Elec bolt icon seems wrong.png
2018-08-03 14:30 NormalPerson7 Note Added: 0032492
2018-08-03 16:56 aidanholm Status new => assigned
2018-08-03 16:56 aidanholm Assigned To => aidanholm
2018-08-03 18:22 aidanholm Note Added: 0032493
2018-08-03 18:22 aidanholm Status assigned => resolved
2018-08-03 18:22 aidanholm Fixed in Branch => longterm development (0.23+)
2018-08-03 18:22 aidanholm Resolution open => done
2018-08-03 21:47 RoGGa Note Added: 0032496
2018-08-03 21:49 RoGGa Note Edited: 0032496
2018-08-03 22:17 RoGGa File Added: 0011580 other monster spell icon missing.png
2018-08-03 22:18 RoGGa Issue Monitored: RoGGa


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker