Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011574 [DCSS] Bug Report minor always 2018-07-31 17:05 2018-09-11 07:02
Reporter RoGGa View Status public  
Assigned To advil
Priority normal Resolution reopened  
Status new   Product Branch 0.22 development branch
Summary 0011574: Windows Trunk downloads 1 week old on http://crawl.develz.org/trunk/ [^]
Description
see screen capture
Additional Information
Tags No tags attached.
Attached Files png file icon Windows Trunk not updated in a week.png [^] (25,542 bytes) 2018-07-31 17:05

- Relationships

-  Notes
(0032469)
advil (developer)
2018-08-01 15:22

Cross-compilation was broken, but gammafunk fixed it in https://github.com/crawl/crawl/commit/557ef7ec2e4a33fc71 [^]

It should go back to daily builds now. However, because trunk builds are now 0.23 builds, someone will need to manually update the download page to show the 023-a download links. In the meantime, you can find the latest one at (the links can be manually constructed from the version numbers that Gretell anounces): http://crawl.develz.org/trunk/crawl_tiles-0.23-a0-8-gb809bb7.zip [^]
(0032480)
RoGGa (reporter)
2018-08-01 21:07

Great! Thanks for the DL link and the Gretell knowledge.

I'm Looking at http://s-z.org/crawl-dev/ [^] , and wondering:

Now that feature freeze is in effect, will there be DLs available for 0.22-b1? Or do bug fixes get applied to both 0.22-b1 and 0.23-a0 making that irrelevant?
It seems the latter is the case but difficult to tell if it always is since <Cheibriados> doesn't process both at the somewhat the same time.
(0032481)
advil (developer)
2018-08-01 21:10

I don't think we do any automated beta builds, but nearly everything that gets pushed during a feature freeze should be cherry-picked to both branches (usually pushed to 0.23 and cherry-picked to the stable branch, which is the beta version now). The stable release is in about a week.
(0032497)
RoGGa (reporter)
2018-08-04 20:03

I haven't seen Gretell announce Windows builds since the one in advil's note above.
(0032592)
RoGGa (reporter)
2018-08-27 22:36
edited on: 2018-08-27 22:45

I'm just reopening this since the last trunk update on http://crawl.develz.org/trunk/ [^] is over a month old.

If one of the issues is with updating that page, I'd like to suggest to temporarily place trunk updates in a folder like:
http://crawl.develz.org/release/trunk/ [^]

Edit: I've looked at http://crawl.develz.org/trunk/archive.html [^]
and there hasn't been a gap of a week or more since v0.15 so this is obviously quite out or the ordinary.

(0032617)
RoGGa (reporter)
2018-09-10 00:34

It would be nice if someone could provide some details as to why this is still not fixed.
Is it due to something related to: http://crawl.develz.org/trunk/ [^] ?
...or related to Travis?
...or waiting for v0.22.1 to be released?
(0032618)
advil (developer)
2018-09-10 22:47

This is one of those pieces of dcss infastructure where someone volunteered to set it up a very long time ago, but is no longer very active, so it typically takes them a bit to get to server maintenance tasks like this (they've already been pinged). We don't really know why it's not working as no one else who is around these days has the right access to check the script itself. We do know that the build script is not generating files at all since a month or so ago, and (independently of that) the web page also needs to be edited for 0.23; we've also verified that cross-compiling itself is currently working. Hopefully this will be fixed soon, but I'm not sure I can promise more than that.

We are also looking into whether nightly builds like this can be done on a service like travis instead, but that is still preliminary.
(0032619)
RoGGa (reporter)
2018-09-11 07:02

Thanks advil for the update.

FYI, I like to play the latest trunk offline so that I can test the latest commits when I come across those in a game.
It's my little way of giving back to the community.

I guess I'll need to look into compiling myself if I want to keep up with the commits offline. But I'll wait until v0.22.1 is out with the new ghost store.

Keep up the great work!

- Issue History
Date Modified Username Field Change
2018-07-31 17:05 RoGGa New Issue
2018-07-31 17:05 RoGGa File Added: Windows Trunk not updated in a week.png
2018-08-01 15:22 advil Note Added: 0032469
2018-08-01 15:22 advil Status new => resolved
2018-08-01 15:22 advil Fixed in Branch => 0.22 development branch
2018-08-01 15:22 advil Resolution open => done
2018-08-01 15:22 advil Assigned To => advil
2018-08-01 21:07 RoGGa Note Added: 0032480
2018-08-01 21:10 advil Note Added: 0032481
2018-08-04 20:03 RoGGa Note Added: 0032497
2018-08-27 22:36 RoGGa Note Added: 0032592
2018-08-27 22:36 RoGGa Status resolved => new
2018-08-27 22:36 RoGGa Resolution done => reopened
2018-08-27 22:45 RoGGa Note Edited: 0032592
2018-09-10 00:34 RoGGa Note Added: 0032617
2018-09-10 22:47 advil Note Added: 0032618
2018-09-11 07:02 RoGGa Note Added: 0032619


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker