Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011569 [DCSS] Documentation trivial always 2018-07-28 16:40 2018-08-01 21:38
Reporter RoGGa View Status public  
Assigned To advil
Priority normal Resolution done  
Status closed   Product Branch 0.22 old branch
Summary 0011569: in \Crawl\docs\keybind.txt, no reference to TAB or Shift-TAB
Description I wanted to invert TAB and Shift-TAB but in \keybind.txt there is no reference to those keys.
My guess is they are technically not key mappings but they are also not referenced in \Crawl\docs\macros_guide.txt

Using github, I was able to find what I was looking for by doing a search for: Shift-Tab
but I think that is too technical a way to find such info.

Also since the answer I was looking for was in the file:
 crawl-ref/source/dat/clua/autofight.lua
I think the following should be added to another file, preferably keybind.txt and/or macros_guide.txt

===hit_closest (Tab by default)
===hit_closest_nomove (Shift-Tab by default)
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0032464)
advil (administrator)
2018-07-31 02:39

These are indeed regular keybinds (which are mappings of key combinations to CMD_... values) rather than macros. The difference is that their actions are implemented in lua, rather than c++, so that leads to functions from the .lua files you mention being exposed to the lua API from there.

Added to keybind.txt in https://github.com/crawl/crawl/commit/af6b6eebfca6250d74d5419f26dbce7bb0533353 [^]

- Issue History
Date Modified Username Field Change
2018-07-28 16:40 RoGGa New Issue
2018-07-31 02:39 advil Note Added: 0032464
2018-07-31 02:39 advil Status new => resolved
2018-07-31 02:39 advil Fixed in Branch => 0.22 development branch
2018-07-31 02:39 advil Resolution open => done
2018-07-31 02:39 advil Assigned To => advil
2018-08-01 21:38 RoGGa Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker