Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011561 [DCSS] Documentation trivial always 2018-07-23 20:27 2018-08-01 21:42
Reporter RoGGa View Status public  
Assigned To advil
Priority normal Resolution done  
Status closed   Product Branch 0.22 old branch
Summary 0011561: in the Help's "List of Commands" (via keys: ??), it still states "r: Read a scroll or a book"
Description With the new spell library, reading a book is automatic when picking up a book.

Also, the M key should state something slightly different than:
Memorize a new spell from a book

In Hints mode the limited list of commands also has 2 references to Read a book. (See 2nd attachment)

Additional Information
Tags No tags attached.
Attached Files png file icon Llist of commands-read a book.png [^] (108,058 bytes) 2018-07-23 20:27
png file icon Hints mode-list of commands-read a book.png [^] (222,202 bytes) 2018-07-23 20:28
png file icon 0011561 List of commands-read a book.png [^] (131,788 bytes) 2018-07-28 16:51

- Relationships

-  Notes
(0032424)
RoGGa (reporter)
2018-07-24 03:00

also in hints.cc, starting at line 924:

text = "However, as a conjurer you will want to deal with it using "
        "magic. If you have a look at your spellbook from your "
           "<w>i</w>nventory, you'll find an explanation of how to do "
           "this."
    "<tiles>\nAs a short-cut you can also <w>right-click</w> on your "
        "book in your inventory to read its description.</tiles>";
(0032426)
RoGGa (reporter)
2018-07-24 03:33

also in crawl-ref/source/dat/descript/tutorial.txt
at line 642:

<input>$cmd[CMD_READ]</input> read a book to see spell descriptions
(0032457)
RoGGa (reporter)
2018-07-28 16:54

Unable to delete 1st attachment. Please see 3rd attachment instead since there are 2 instances that need to be corrected.
(0032458)
NormalPerson7 (reporter)
2018-07-28 17:55

You can still use 'r' to read a book from the floor that you haven't yet picked up (although identical functionality exists with 'x' I think), so it isn't completely outdated.
(0032463)
advil (administrator)
2018-07-31 02:31

I think I got all of these in b7b0c8bd75b

- Issue History
Date Modified Username Field Change
2018-07-23 20:27 RoGGa New Issue
2018-07-23 20:27 RoGGa File Added: Llist of commands-read a book.png
2018-07-23 20:28 RoGGa File Added: Hints mode-list of commands-read a book.png
2018-07-24 03:00 RoGGa Note Added: 0032424
2018-07-24 03:33 RoGGa Note Added: 0032426
2018-07-28 16:51 RoGGa File Added: 0011561 List of commands-read a book.png
2018-07-28 16:54 RoGGa Note Added: 0032457
2018-07-28 17:55 NormalPerson7 Note Added: 0032458
2018-07-31 02:31 advil Note Added: 0032463
2018-07-31 02:31 advil Status new => resolved
2018-07-31 02:31 advil Fixed in Branch => 0.22 development branch
2018-07-31 02:31 advil Resolution open => done
2018-07-31 02:31 advil Assigned To => advil
2018-08-01 21:42 RoGGa Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker