Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011549 [DCSS] Bug Report crash always 2018-07-22 01:10 2018-08-18 01:16
Reporter Siegurt View Status public  
Assigned To aidanholm
Priority normal Resolution done  
Status closed   Product Branch 0.22 old branch
Summary 0011549: Game crashes on skill level reached
Description I see the message about my spellcasting reaching level 4, and it requiring me to select a new skill, then the game crashes immediately.

The attached save file can reproduce the error by killing the monster on screen

I've attached both the crash log and save file.
Additional Information
Tags No tags attached.
Attached Files ? file icon Anglot.cs [^] (56,859 bytes) 2018-07-22 01:10
txt file icon crash-Anglot-20180721-170849.txt [^] (14,625 bytes) 2018-07-22 01:12 [Show Content]

- Relationships
duplicate of 0011527closedaidanholm Crash when all skill targets met 

-  Notes
(0032387)
Siegurt (reporter)
2018-07-22 01:18

Further detail: If I enable a second skill *before* leveling up spellcasting, the game does not crash, it appears that the crash bug is specific to achieving your target skill level in the only skill you are training.
(0032388)
Siegurt (reporter)
2018-07-22 06:09

Confirmed that the bug still occurs in 0.22-a0-799-g88f5e90, Reproduced it with a new character.
(0032406)
aidanholm (developer)
2018-07-23 03:37

Thanks for reporting! This was fixed by advil at 4c1e2d5471; should be working fine now.
(0032560)
Siegurt (reporter)
2018-08-18 01:16

Seems to be resolved.

- Issue History
Date Modified Username Field Change
2018-07-22 01:10 Siegurt New Issue
2018-07-22 01:10 Siegurt File Added: Anglot.cs
2018-07-22 01:12 Siegurt File Added: crash-Anglot-20180721-170849.txt
2018-07-22 01:18 Siegurt Note Added: 0032387
2018-07-22 06:09 Siegurt Note Added: 0032388
2018-07-22 15:10 aidanholm Relationship added duplicate of 0011527
2018-07-23 03:37 aidanholm Note Added: 0032406
2018-07-23 03:37 aidanholm Status new => resolved
2018-07-23 03:37 aidanholm Fixed in Branch => 0.22 development branch
2018-07-23 03:37 aidanholm Resolution open => done
2018-07-23 03:37 aidanholm Assigned To => aidanholm
2018-08-18 01:16 Siegurt Note Added: 0032560
2018-08-18 01:16 Siegurt Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker