Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011545 [DCSS] Bug Report minor always 2018-07-21 18:48 2018-07-25 17:18
Reporter geewiz1 View Status public  
Assigned To aidanholm
Priority normal Resolution done  
Status resolved   Product Branch 0.22 old branch
Summary 0011545: When using x or X, text displayed is not visible
Description When using x or X to enter eXamine mode and using a subsequent command that should display text (e.g. v or ?) the overlay/modal with the desired test is not visible. It seems to be getting rendered off screen, perhaps? The code thinks the modal is up; the screen is frozen until you hit something (e.g. escape) to cancel the modal, at which point you are back in eXamine mode; you just can't see anything.

Works in 21.0 and worked in trunk until at least ~2 weeks ago.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0032386)
aidanholm (developer)
2018-07-21 18:58

Thanks for reporting! This was fixed in trunk; at this time, only CAO is missng the fix, but it should land within an hour or so.
(0032427)
geewiz1 (reporter)
2018-07-24 06:25

Hmm -- cao has been updated a few versions since then and it's still happening for me, in a fresh window, on both safari and chrome...
(0032442)
aidanholm (developer)
2018-07-25 05:35

What version is displayed on the ?V screen? CAO is working for me, at version 0.22-a0-832-g4a1e013.
It's possible your browser is caching files from the old version.
(0032443)
geewiz1 (reporter)
2018-07-25 17:18

Thanks for the attention!

I am in 0.22-a0-832-g4a1e013, in private/incognito windows in both safari and chrome. In fact you are correct, xv now works, BUT oddly enough Xv still does not. when I enter X mode it hides the message history which shifts the screen slightly, perhaps that's related? In any case the v panel is still invisible in X mode.

- Issue History
Date Modified Username Field Change
2018-07-21 18:48 geewiz1 New Issue
2018-07-21 18:58 aidanholm Note Added: 0032386
2018-07-21 18:58 aidanholm Status new => resolved
2018-07-21 18:58 aidanholm Fixed in Branch => 0.22 development branch
2018-07-21 18:58 aidanholm Resolution open => done
2018-07-21 18:58 aidanholm Assigned To => aidanholm
2018-07-24 06:25 geewiz1 Note Added: 0032427
2018-07-25 05:35 aidanholm Note Added: 0032442
2018-07-25 17:18 geewiz1 Note Added: 0032443


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker