Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011532 [DCSS] Bug Report block always 2018-07-16 21:28 2018-07-17 18:52
Reporter NormalPerson7 View Status public  
Assigned To aidanholm
Priority normal Resolution done  
Status resolved   Product Branch 0.22 old branch
Summary 0011532: Console client flickers and does not load at all when manually compiled.
Description I have tried to manually compile Crawl on Windows 10 using msys2 mingw64 with version iterations 0.22-a0-757-gdba82d8 and 0.22-a0-766-g08e7145, and both times I have always gotten the flickering effect shown in this gif upon running the start crawl command: https://imgur.com/a/aJEcOny [^] . This makes it impossible even to play Crawl, because the console version doesn't even load. I have confirmed that some other Windows users also experience this effect.

I will note specifically that I am using the master branch of the NormalPerson7/crawl repository on Github, which is now even with crawl:master up to commit 08e7145. I maintain this branch as an exact replica of crawl:master for testing purposes, using only the git commands `fetch upstream` and `rebase upstream/master` to update it.

It is clear something was broken in this respect during the merging of ui-overhaul, because performing a reset back to commit 1015d74 (the last commit before ui-overhaul was fast-forwarded on top) has the console version of Crawl work fine.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0032361)
NormalPerson7 (reporter)
2018-07-17 15:15

I have tracked this down using `git bisect` to the following commit: https://github.com/crawl/crawl/commit/6f189af7ca974318f280b0a3ff6c4d787c40e167 [^] .
(0032363)
aidanholm (developer)
2018-07-17 18:51

Thanks! Fixed at 9746042cce.

- Issue History
Date Modified Username Field Change
2018-07-16 21:28 NormalPerson7 New Issue
2018-07-17 15:15 NormalPerson7 Note Added: 0032361
2018-07-17 18:51 aidanholm Note Added: 0032363
2018-07-17 18:51 aidanholm Status new => resolved
2018-07-17 18:51 aidanholm Fixed in Branch => 0.22 development branch
2018-07-17 18:51 aidanholm Resolution open => done
2018-07-17 18:51 aidanholm Assigned To => aidanholm


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker