Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011530 [DCSS] Bug Report trivial always 2018-07-16 13:00 2018-07-16 15:24
Reporter TAS2012 View Status public  
Assigned To aidanholm
Priority normal Resolution done  
Status resolved   Product Branch 0.22 old branch
Summary 0011530: Player has to guess how to interact with the Altar screen
Description Playing on CDO, SSH with PuTTY, username TAS2012.

1. I stand on an altar and press < to pray. I get the standard response ("You kneel at the altar of Okawaru." followed by "--more--") and press Space for more and then enter the "altar screen" ("Warmaster Okawaru").
2. There is no information about interaction other than the "[!/^] Overview|Powers|Wrath" line. I press Space or Enter trying to display something more or interact with the altar, but nothing happens. If I press the ! or ^ keys it works as normal (cycling throuh information subscreens). If I press Esc I exit back to the main game screen.
3. I press Y or Shift-Y and the game responds with "Do you wish to join this religion?". Pressing Y, N, Shift-Y or Shift-N in response works as expected (including "[Y]es or [n]o only, please." for the non-Shift commands).

Expected result: Some indication to the player about how to interact with the screen other than !/^ to cycle through information sub-screens, specifically about how to join the religion, without the player having tog guess about pressing Y/N keys.

Trivial severity because easily worked around as described above.
Additional Information
Tags ui-overhaul
Attached Files

- Relationships

-  Notes
(0032352)
aidanholm (developer)
2018-07-16 15:24

Thanks for the comprehensive report! I've added some keyhelp text.

Space/enter used to work, but the description above the "Overview|Powers|Wrath" line is actually contained within a scroller widget, which consumed all space/enter keys (both these keys are used to scroll down). I've made it so space/enter do not scroll this particular scroller, and so pressing them will work as expected from now on.

- Issue History
Date Modified Username Field Change
2018-07-16 13:00 TAS2012 New Issue
2018-07-16 14:12 TAS2012 Issue Monitored: TAS2012
2018-07-16 14:46 aidanholm Tag Attached: ui-overhaul
2018-07-16 15:24 aidanholm Note Added: 0032352
2018-07-16 15:24 aidanholm Status new => resolved
2018-07-16 15:24 aidanholm Fixed in Branch => 0.22 development branch
2018-07-16 15:24 aidanholm Resolution open => done
2018-07-16 15:24 aidanholm Assigned To => aidanholm


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker