Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011528 [DCSS] Bug Report trivial always 2018-07-16 12:36 2018-07-16 15:21
Reporter TAS2012 View Status public  
Assigned To aidanholm
Priority normal Resolution done  
Status resolved   Product Branch 0.22 old branch
Summary 0011528: After leaving Overview screen, game screen is not redrawn
Description Playing on CDO, SSH with PuTTY, username TAS2012.

1. I press Ctrl+O for Overview page. It displays as normal.
2. I press Esc to return to standard game screen.

Result: It only displays the map and a few status items (noise level "Noise: ---------", hunger level "Engorged"). Nothing else, including message history.

Expected result: Game screen displayed in full, as before entering the Overview screen.

Trivial severity because it is easily worked around, for example Ctrl+P (show previous messages) followed by Esc restores the screen fully.
Additional Information
Tags ui-overhaul
Attached Files

- Relationships

-  Notes
(0032349)
TAS2012 (reporter)
2018-07-16 13:31

Same thing seemed to happen when I entered O:1 (for the first time). Has not happened before when just moving between D:levels.
(0032350)
TAS2012 (reporter)
2018-07-16 13:58
edited on: 2018-07-16 13:59

And the same thing again when exiting L:1 back to Dungeon.

Using auto-travel at both times.

(0032351)
aidanholm (developer)
2018-07-16 15:20

Thanks for reporting! Fixed in trunk at 2141c5b775

- Issue History
Date Modified Username Field Change
2018-07-16 12:36 TAS2012 New Issue
2018-07-16 13:31 TAS2012 Note Added: 0032349
2018-07-16 13:58 TAS2012 Note Added: 0032350
2018-07-16 13:59 TAS2012 Note Edited: 0032350
2018-07-16 14:12 TAS2012 Issue Monitored: TAS2012
2018-07-16 14:46 aidanholm Tag Attached: ui-overhaul
2018-07-16 15:20 aidanholm Note Added: 0032351
2018-07-16 15:21 aidanholm Status new => resolved
2018-07-16 15:21 aidanholm Fixed in Branch => 0.22 development branch
2018-07-16 15:21 aidanholm Resolution open => done
2018-07-16 15:21 aidanholm Assigned To => aidanholm


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker