Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011520 [DCSS] Bug Report minor always 2018-07-14 19:37 2018-08-28 23:08
Reporter pedant View Status public  
Assigned To aidanholm
Priority normal Resolution done  
Status closed   Product Branch 0.22 old branch
Summary 0011520: Few issues with UI update
Description 1. 'Hostile' text is being truncated on ability menu screen: https://imgur.com/a/9A54b61 [^]

2. Message log (ctrl+P) always starts from the oldest message now instead of the most recent. The old behaviour was better. I want to see what just happened.

3. (A more subjective gripe.) Top most item of the inventory menu is faded out. This makes it look too much like it is a grey, useless item: https://imgur.com/a/BJ3Z3O6 [^]

(I do like the new boarder though. :))
Additional Information
Tags ui-overhaul
Attached Files

- Relationships

-  Notes
(0032335)
aidanholm (developer)
2018-07-14 19:47

Thanks for reporting, and for the helpful screenshots!

1. Thanks, this should be relatively easy to fix.

2) This is a bug; already fixed at 6546e2e, should be live soon

3) The fade at the top and the bottom is supposed to indicate that there's more content available to scroll. Scrollbars currently only appear on mouseover, and I haven't gotten around to changing that that yet. I can see how that could be misinterpreted though, so I'll think about possibly changing it.
(0032336)
xbon (reporter)
2018-07-15 01:03

Since this is on topic of UI update, I thought I'd comment here: https://i.imgur.com/bARzuHn.png [^] colors aren't working for the god screen it seems like? it appears in <> boxes and doesn't properly function/pushes text out of orientation, etc.
(0032338)
kitchen_ace (reporter)
2018-07-15 03:28

Colours not working for the (A)bilites screen either.
(0032339)
aidanholm (developer)
2018-07-15 05:31

Thanks; the god and abilities screens are fixed now.
(0032343)
kitchen_ace (reporter)
2018-07-15 10:39

Aidanholm: The description for spellbooks also has no colours as of the time of my last post. Can't check the latest updates for a bit so maybe you've fixed it already.
(0032360)
aidanholm (developer)
2018-07-17 13:49

I don't see any issue with spellbook descriptions (tested with "?/i book of air"); there are no colour tags visible.
(0032364)
kitchen_ace (reporter)
2018-07-17 22:48

Fixed in latest trunk.
(0032383)
aidanholm (developer)
2018-07-20 18:23

The ability menu text issue was fixed at 3b2440b, and the gradients at the top/bottom of scrollers were adjusted at b0d9f32, and are now harder to get confused by.

- Issue History
Date Modified Username Field Change
2018-07-14 19:37 pedant New Issue
2018-07-14 19:38 pedant Tag Attached: ui-overhaul
2018-07-14 19:47 aidanholm Note Added: 0032335
2018-07-15 01:03 xbon Note Added: 0032336
2018-07-15 03:28 kitchen_ace Note Added: 0032338
2018-07-15 05:31 aidanholm Note Added: 0032339
2018-07-15 10:39 kitchen_ace Note Added: 0032343
2018-07-17 13:49 aidanholm Note Added: 0032360
2018-07-17 22:48 kitchen_ace Note Added: 0032364
2018-07-20 18:23 aidanholm Note Added: 0032383
2018-07-20 18:23 aidanholm Status new => resolved
2018-07-20 18:23 aidanholm Fixed in Branch => 0.22 development branch
2018-07-20 18:23 aidanholm Resolution open => done
2018-07-20 18:23 aidanholm Assigned To => aidanholm
2018-08-28 23:07 pedant Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker