Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011518 [DCSS] Bug Report minor have not tried 2018-07-13 06:55 2018-07-26 21:37
Reporter RoGGa View Status public  
Assigned To
Priority normal Resolution no change required  
Status closed   Product Branch experimental branch
Summary 0011518: no auto-pickup for Phantom Mirror since not on un/recognised list
Description I almost missed picking up a Phantom Mirror since it is neither on on unrecognized list (\\) nor the recognized list (\)
...unless it's part of the Recognized items: miscellaneous (under the Other Items category)

Issue#2: It also seems to be sitting under Gold only to be seen after the auto-explore picked up the gold:

You now have 248 gold pieces (gained 49).
You see here a phantom mirror.
You enter the shallow water.
Moving in this stuff is going to be slow.
Key pressed, stopping explore.

Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0032434)
ebering (developer)
2018-07-24 19:22

Phantom Mirrors are considered "miscellaneous" under auto pickup.

A stack with multiple items is not fully known to the player until you step into the square with the stack. However, I think the issue here is with your auto pickup settings. Having tested with miscellaneous auto pickup on, the game correctly picks up a phantom mirror even if it is lower in a stack, and does not pick it up when misc. auto pickup is off.
(0032446)
RoGGa (reporter)
2018-07-26 17:50

I've been giving this some thought and I think the default option for what is picked up automatically should be changed for some items.

Currently, the following is not picked up automatically and I think that should be changed in case they show up in a pile of items where that item is not the first visible item:

a - unknown magical staves
v - miscellaneous
(0032450)
ebering (developer)
2018-07-26 21:34

This can be changed by the user setting autopickup in your init.txt;

The default behavior is the behavior described in this ticket, thus crawl is working as intended and this is not a bug. Since any default won't be desirable to 100% of players, autopickup is configurable.

To get the auto pickup you think should happen (add all magical staves and misc items) use

autopickup = $?!+"/%|}

If you want to include consumable misc items only, leave the default autopickup and use

autopickup_exceptions += <phantom_mirror, <box_of_beasts, <sack_of_spiders

- Issue History
Date Modified Username Field Change
2018-07-13 06:55 RoGGa New Issue
2018-07-24 19:22 ebering Note Added: 0032434
2018-07-24 19:22 ebering Status new => closed
2018-07-24 19:23 ebering Resolution open => no change required
2018-07-26 17:50 RoGGa Note Added: 0032446
2018-07-26 17:50 RoGGa Status closed => new
2018-07-26 17:50 RoGGa Resolution no change required => reopened
2018-07-26 21:34 ebering Note Added: 0032450
2018-07-26 21:37 ebering Status new => closed
2018-07-26 21:37 ebering Resolution reopened => no change required


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker