Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011512 [DCSS] Documentation text always 2018-07-09 00:31 2018-08-10 06:27
Reporter RoGGa View Status public  
Assigned To gammafunk
Priority normal Resolution done  
Status closed   Product Branch 0.21 stable branch
Summary 0011512: FAQ.txt still contains: by 'p'raying on the altar
Description Line 224 & 225:
Whenever you encounter an altar, be sure to read the corresponding god's
description (by 'p'raying on the altar) and take your time in deciding whether

Also did a quick search for: 'p'raying
on https://github.com/crawl/crawl/search?q=%27p%27raying&unscoped_q=%27p%27raying [^]
and there seems to be 2 references in file: crawl-ref/source/hints.cc

3639 ostr << "As <w>p</w>raying on the altar will tell you, "
3640 << god_name(altar_god) << " only accepts worship from "
...
3644 "For other gods, you'll be able to join the faith "
3645 "by <w>p</w>raying at their altar.";
Additional Information
Tags No tags attached.
Attached Files png file icon p-for-pray.png [^] (106,300 bytes) 2018-07-23 17:49

- Relationships

-  Notes
(0032327)
RoGGa (reporter)
2018-07-09 03:22
edited on: 2018-07-09 03:31

I dug a bit deeper and found another reference in the file: hints.txt
(crawl/crawl-ref/source/dat/descript/hints.txt)
https://github.com/crawl/crawl/blob/aef71b82751e6fec919a661061d279572e000bf9/crawl-ref/source/dat/descript/hints.txt [^]

155 %%%%
156 dissection reminder
157
158 If you don't want to eat it, consider offering this corpse up under prayer
159 (<input>$cmd[CMD_PRAY]</input>) as a sacrifice to {{ return you.god() }}.
160 <localtiles>You can also chop up any corpse that shows in the floor part of
161 your inventory tiles by clicking on it with your <input>left mouse
162 button</input>. </localtiles>Whenever you view a corpse while in hint mode you
163 can reread this information.
164 %%%%

(0032365)
Pekkekke (reporter)
2018-07-18 01:55

The reference in the note appears to be outdated. The version listed has not been updated since 2014. The current version of hints.txt does not seem to have this reminder. It is possible that I simply missed that particular dissection reminder notice, but I don't think that is the case.

I've replaced instances of 'p'raying with "praying with '>' " in the other files and have submitted a pull request for this change.
(0032371)
RoGGa (reporter)
2018-07-19 06:40

You're right. The linked file in my Note above wasn't in the Master branch. My bad...I'm still getting familiar with github.

(for cross ref: https://github.com/crawl/crawl/pull/821) [^]
(0032418)
RoGGa (reporter)
2018-07-23 17:47
edited on: 2018-07-23 18:14

I found another 'p' for pray.
See attached screen capture: p-for-pray.png

I tried to find out what file it's in and there's 4 instances of: >p<
in: crawl-ref/source/hints.cc
The Sif Muna text is no longer valid since you are no longer required to have a spell book to join.

As for the html code showing up as text, this has been reported in:
https://crawl.develz.org/mantis/view.php?id=11539 [^]

(0032483)
RoGGa (reporter)
2018-08-01 22:25

The FAQ.txt fix is good ...but the new line (0000225) is longer than 80chars.
Don't know if this matters :s

Changes were made to hints.cc about: >p<

As for the Sif Muna in hints.cc, I've reported it in bug report https://crawl.develz.org/mantis/view.php?id=11578 [^]
...so please close this one.
(0032539)
gammafunk (developer)
2018-08-10 02:16

Fixed the FAQ.txt wrap in 0.23-a0-77-g5c563b8, thanks. All issues in this report addressed, so I'm closing this one.

- Issue History
Date Modified Username Field Change
2018-07-09 00:31 RoGGa New Issue
2018-07-09 03:22 RoGGa Note Added: 0032327
2018-07-09 03:31 RoGGa Note Edited: 0032327
2018-07-18 01:55 Pekkekke Note Added: 0032365
2018-07-18 01:55 Pekkekke Note Added: 0032366
2018-07-18 01:56 Pekkekke Note Deleted: 0032366
2018-07-19 06:40 RoGGa Note Added: 0032371
2018-07-23 17:47 RoGGa Note Added: 0032418
2018-07-23 17:48 RoGGa Note Added: 0032419
2018-07-23 17:49 RoGGa Note Deleted: 0032419
2018-07-23 17:49 RoGGa File Added: p-for-pray.png
2018-07-23 17:58 RoGGa Note Edited: 0032418
2018-07-23 18:14 RoGGa Note Edited: 0032418
2018-08-01 22:25 RoGGa Note Added: 0032483
2018-08-10 02:16 gammafunk Note Added: 0032539
2018-08-10 02:16 gammafunk Status new => resolved
2018-08-10 02:16 gammafunk Resolution open => done
2018-08-10 02:16 gammafunk Assigned To => gammafunk
2018-08-10 06:27 RoGGa Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker