Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011506 [DCSS] Bug Report minor sometimes 2018-07-05 17:37 2018-07-08 16:11
Reporter agentchuck View Status public  
Assigned To advil
Priority normal Resolution done  
Status resolved   Product Branch 0.21 ancient branch
Summary 0011506: Vault wardens seem to be clearing freezing clouds
Description In vaults and using freezing cloud liberally. The clouds will last 20-40 auts at 7 pips of spell power. And the clouds will also clear gradually, going from large clouds to small clouds, to completely cleared.

However, when a vault warden is involved in the battle, the clouds can sometime clear instantaneously. There is no flavor text to indicate that anything has transpired. The clouds are just gone. I have not observed this behaviour against other foes.

A bit of log is below. In this instance the clouds didn't even show up on the screen. They just damaged him once and were gone.

 You barely miss the vault warden. You grab the vault warden.
 You pierce the vault warden, but do no damage.
 The vault warden is lightly wounded.
_You constrict the vault warden.
 You feel a surge of power!
 You constrict the vault warden.
 The vault warden is engulfed in freezing vapours.
_You lose your grip on the vault warden. You block the vault warden's attack.
 You thump the vault warden! You burn the vault warden.
 You grab the vault warden.
 You pierce the vault warden, but do no damage.
 The vault warden is heavily wounded.
 You constrict the vault warden, but do no damage.
_You lose your grip on the vault warden. You block the vault warden's attack.
 You bludgeon the vault warden!! You burn the vault warden!
 You grab the vault warden. You pierce the vault warden.
 You tentacle-slap the vault warden.
 The vault warden is almost dead.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0032322)
RoGGa (reporter)
2018-07-06 09:31
edited on: 2018-07-06 09:40

I've come across something similar myself once.
In my case, it seemed to be caused by the Vault Warden closing all doors except for a door between my character and the VW.
My guess is: the code shuts all doors in LOS and sometimes reopens the one in between the character and the VW , and in the process removes the Freezing Cloud.
(I've also experienced a vault door being locked for a few turns with the VW on the other side of it, which seems a bit silly.)

(0032325)
advil (administrator)
2018-07-08 16:11

Thanks, this is probably due to door sealing and should be fixed in https://github.com/crawl/crawl/commit/acb6733a4425 [^]

I don't see the door sealing message in the quoted log, but I suspect it would be there in the full log.

- Issue History
Date Modified Username Field Change
2018-07-05 17:37 agentchuck New Issue
2018-07-06 09:31 RoGGa Note Added: 0032322
2018-07-06 09:40 RoGGa Note Edited: 0032322
2018-07-06 09:40 RoGGa Note Edited: 0032322
2018-07-08 16:11 advil Note Added: 0032325
2018-07-08 16:11 advil Status new => resolved
2018-07-08 16:11 advil Fixed in Branch => 0.22 development branch
2018-07-08 16:11 advil Resolution open => done
2018-07-08 16:11 advil Assigned To => advil


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker