Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011504 [DCSS] Bug Report minor always 2018-07-01 22:27 2018-07-31 02:45
Reporter Muffindrake View Status public  
Assigned To advil
Priority normal Resolution done  
Status resolved   Product Branch 0.22 stable branch
Summary 0011504: Polymorphing a frenzied shapeshifter causes it to become "indifferent"
Description Steps to reproduce:
- procure a shapeshifter
- frenzy it
- zap a polymorph wand at it
- observe (indifferent) status

This indifference is permanent, persists through leaving the floor, causes the monster to behave neutral to you, but continue to attack other monsters.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0032317)
Muffindrake (reporter)
2018-07-01 22:33

Actually, polymorphing _any_ frenzied monster will cause it to become indifferent. _Now_ I'm not sure whether that's intended behaviour or not.
(0032318)
Muffindrake (reporter)
2018-07-01 23:00

Also note that the indifference is cancelled by attacking the monster, allowing you to keep a pseudo-summon through stairs as long as you have polymorph.
(0032466)
advil (developer)
2018-07-31 02:44

Fixed in https://github.com/crawl/crawl/commit/337e1da0210d [^]

- Issue History
Date Modified Username Field Change
2018-07-01 22:27 Muffindrake New Issue
2018-07-01 22:33 Muffindrake Note Added: 0032317
2018-07-01 23:00 Muffindrake Note Added: 0032318
2018-07-31 02:44 advil Note Added: 0032466
2018-07-31 02:44 advil Status new => resolved
2018-07-31 02:44 advil Fixed in Branch => 0.22 development branch
2018-07-31 02:44 advil Resolution open => done
2018-07-31 02:44 advil Assigned To => advil


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker