Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011441 [DCSS] Bug Report minor have not tried 2018-04-07 01:22 2018-08-01 17:40
Reporter Leszczynek View Status public  
Assigned To aidanholm
Priority normal Resolution done  
Status resolved   Product Branch 0.22 ancient branch
Summary 0011441: Long lists cut off when spectating online
Description When spectating a game where the player views a long list (e.g. 4 pages long while picking up from a stash, see attached screen), at a certain point items get cut off and are replaced with "..." instead. If the player chooses one of the items hidden behind "...", it becomes visible to the spectator as well.

Noticed this with picking up and identified items lists.
Additional Information
Tags ui-overhaul
Attached Files png file icon incomplete pick up list.png [^] (45,554 bytes) 2018-04-07 01:22

- Relationships

-  Notes
(0032163)
aidanholm (developer)
2018-04-07 06:12

This is easiest to reproduce if the spectator scrolls down; unloaded items will be visible until the spectated player also scrolls down. This happens because menus are loaded in chunks of 50 items based on the current scroll position of the player, not the spectator; crawl rarely distinguishes between recipients (and their client-side state) and tends to send the the same JSON messages to each.

This is fixed in the ui-overhaul branch; I removed the menu chunking optimization and just send the entire menu every time.
(0032477)
aidanholm (developer)
2018-08-01 17:40

The ui-overhaul branch has been merged.

- Issue History
Date Modified Username Field Change
2018-04-07 01:22 Leszczynek New Issue
2018-04-07 01:22 Leszczynek File Added: incomplete pick up list.png
2018-04-07 06:12 aidanholm Tag Attached: ui-overhaul
2018-04-07 06:12 aidanholm Note Added: 0032163
2018-08-01 17:40 aidanholm Note Added: 0032477
2018-08-01 17:40 aidanholm Status new => resolved
2018-08-01 17:40 aidanholm Fixed in Branch => 0.22 development branch
2018-08-01 17:40 aidanholm Resolution open => done
2018-08-01 17:40 aidanholm Assigned To => aidanholm


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker