Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011436 [DCSS] Bug Report minor have not tried 2018-04-05 03:55 2019-02-04 18:46
Reporter Siegurt View Status public  
Assigned To ebering
Priority normal Resolution done  
Status closed   Product Branch experimental branch
Summary 0011436: Amulet of the Acrobat cancels EV bonus with non-actions
Description When doing non actions (going into a menu and canceling, hitting an unknown command like space) the EV bonus from Amulet of the Acrobat is removed.

It seems like non-actions shouldn't cancel the EV bonus.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0032297)
Siegurt (reporter)
2018-06-13 20:18
edited on: 2018-06-13 20:18

So some clarification, the EV bonus is applied during the monster's turn, so really the bonus isn't cancelled, it's more that the display of "an AC bonus was applied last turn" goes away, seemingly indicating that you've lost the bonus, when it really isn't an indicator of a status that *will be* applied but rather an indicator that the status *was* applied, this is possibly confusing, but not strictly speaking wrong. It's hard to say what the right thing to do with indicator for the Acrobat bonus.

(0032323)
RoGGa (reporter)
2018-07-07 23:51
edited on: 2018-07-08 15:13

The amulet of Acrobat seems to deactivate when using stairs and escape hatches...but not when DIGging as a Fo!
(I haven't found a shaft to see if it has the same effect.)

It seems inconsistent with the description that it is active when moving:
"An amulet that allows the user to tumble and roll to evade the blows of their enemies, but only while moving and waiting. ..."

...vs...

"You climb upwards."
"You slide downwards. The hatch slams shut behind you."

The quickest fix to me seems to be: add the Up and Down level caveat to the Amulet's description.

Opinion: Btw, I think it would be very interesting to deactivate the +15 EV bonus when going Up a level (but not when going down) since it would be difficult to "tumble and roll" while climbing upwards!
Doing so going downwards could be comical with the right wording especially if it also included a small loss of HP for stair bruising incurred when an enemy follows you down..

I don't know if this is related to this bug or should be filed as a separate bug.
I tried to get some response in the Tavern but to no avail:
Topic: How does the amulet of the acrobat work in trunk
https://crawl.develz.org/tavern/viewtopic.php?f=5&t=25357 [^]

(0032844)
Karagy (reporter)
2018-12-09 22:05

CDO console, 0.23-a0-550-g7de1f8e.

Amulet of the Acrobat cancels EV bonus when player press ESC key.
No time passed when press ESC and got standard "_Unknown command." message.

Note: for online console - ESC frequently used for check "alive" server status.
(0032971)
ebering (developer)
2019-01-24 01:31

This was adjusted in 0.23-a0-638-gc52245bda8 to always display on the subsequent turn.

- Issue History
Date Modified Username Field Change
2018-04-05 03:55 Siegurt New Issue
2018-06-13 20:18 Siegurt Note Added: 0032297
2018-06-13 20:18 Siegurt Note Edited: 0032297
2018-07-07 23:51 RoGGa Note Added: 0032323
2018-07-07 23:51 RoGGa Note Added: 0032324
2018-07-07 23:51 RoGGa Note Deleted: 0032324
2018-07-08 03:34 RoGGa Note Edited: 0032323
2018-07-08 03:36 RoGGa Note Edited: 0032323
2018-07-08 08:49 RoGGa Issue Monitored: RoGGa
2018-07-08 15:13 RoGGa Note Edited: 0032323
2018-12-09 22:05 Karagy Note Added: 0032844
2019-01-24 01:31 ebering Note Added: 0032971
2019-01-24 01:32 ebering Status new => resolved
2019-01-24 01:32 ebering Resolution open => done
2019-01-24 01:32 ebering Assigned To => ebering
2019-02-04 18:46 Siegurt Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker