Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011430 [DCSS] Bug Report crash sometimes 2018-03-26 15:15 2018-03-26 16:09
Reporter sterilizedmilk View Status public  
Assigned To advil
Priority normal Resolution done  
Status resolved   Product Branch 0.22 old branch
Summary 0011430: tiles crash when compiled with prefix
Description I compile my version of dcss on windows with msys2.
It is fine when I just compile with [make TILES=y] command,
but if use prefix option, that makes problem.

like ~ [make install TILES=y "prefix=crawl"]

with this, you will receive no warning or error on compile.
but game will crash before it make morgue directory.

because program can't find font in prefix/prefix//dat/tiles

well... It still works with console because it doesn't use font...


cause is in makefile:868

  ifneq ($(prefix),)
    DATADIR := $(strip $(prefix))/$(strip $(DATADIR))
        FONTDIR = $(strip $(prefix))/$(strip $(DATADIR))/dat/tiles/

this should be like

  ifneq ($(prefix),)
    DATADIR := $(strip $(prefix))/$(strip $(DATADIR))
        FONTDIR = $(strip $(DATADIR))/dat/tiles/
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0032155)
advil (administrator)
2018-03-26 16:09

Thanks, fixed in https://github.com/crawl/crawl/commit/4c9dbd0d6bff [^]

- Issue History
Date Modified Username Field Change
2018-03-26 15:15 sterilizedmilk New Issue
2018-03-26 16:09 advil Note Added: 0032155
2018-03-26 16:09 advil Status new => resolved
2018-03-26 16:09 advil Fixed in Branch => 0.22 development branch
2018-03-26 16:09 advil Resolution open => done
2018-03-26 16:09 advil Assigned To => advil


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker