Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011405 [DCSS] Bug Report major have not tried 2018-03-04 13:39 2018-03-04 19:39
Reporter NormalPerson7 View Status public  
Assigned To aidanholm
Priority normal Resolution done  
Status resolved   Product Branch 0.22 old branch
Summary 0011405: Tomb card's interaction with branch entrances is funky and unexplained.
Description When the Tomb card is used next to a branch entrance, walls appear around normally, except no wall is placed on the branch entrance. Remaining still will have no effect, and you cannot move into the walls, as expected. However, moving onto the branch entrance tile causes the walls to collapse prematurely.

This should at the very least be explained in the description, but probably should place a wall on the branch entrance as one would expect. This bug is 'major' because this could break streaks or kill characters due to no fault of the player, especially because it seems like the natural thing to do to then escape via the branch entrance when you can see it isn't covered by a wall. Furthermore, the Tomb card is intended to be a reliable emergency escape when enemies are not next to you (especially from high-level decks).

The screenshot shows me losing a life on a felid to this mechanic, having evoked the Tomb card from a legendary deck (with 6*, 8 invo, I would expect the tomb to be perfect at this power level) standing on the dire flail, then moving onto the Lair entrance to try to escape downstairs, then getting shot down by the yaktaur. (I have also confirmed in wizmode that walls are placed on up/down stairs as expected, but never on branch entrances.)
Additional Information
Tags No tags attached.
Attached Files png file icon 2018-03-04 Tomb card and branch entrance behaviour.PNG [^] (608,345 bytes) 2018-03-04 13:39

- Relationships

-  Notes
(0032109)
aidanholm (developer)
2018-03-04 17:54

Thanks for the report. I've fixed the issue with branch entrances (and some other features) not being walled up, and added a note about premature collapse to the tomb card's description.
(0032110)
NormalPerson7 (reporter)
2018-03-04 19:39

Thank you.

- Issue History
Date Modified Username Field Change
2018-03-04 13:39 NormalPerson7 New Issue
2018-03-04 13:39 NormalPerson7 File Added: 2018-03-04 Tomb card and branch entrance behaviour.PNG
2018-03-04 17:54 aidanholm Note Added: 0032109
2018-03-04 17:54 aidanholm Status new => resolved
2018-03-04 17:54 aidanholm Fixed in Branch => 0.22 development branch
2018-03-04 17:54 aidanholm Resolution open => done
2018-03-04 17:54 aidanholm Assigned To => aidanholm
2018-03-04 19:39 NormalPerson7 Note Added: 0032110


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker