Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011314 [DCSS] Bug Report minor always 2017-12-06 17:55 2018-01-30 05:51
Reporter hexaflexagon View Status public  
Assigned To wheals
Priority normal Resolution done  
Status resolved   Product Branch 0.21 ancient branch
Summary 0011314: Monsters won't cast dispel undead on a player gargoyle in lich-form
Description Monsters won't cast dispel undead on a player gargoyle in lich-form. Not sure what else to say. Fought an awful lot of Tzitzimimeh as a lich-form gargoyle and thought it was weird that my force_more for convulsion hadn't gone off once. Tested in wizmode with Josephine and it was pretty obvious: against a lich-form gargoyle she casts no spells whatsoever, change race and she casts dispel undead almost immediately.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0031959)
hexaflexagon (reporter)
2017-12-06 17:59

Looks like it affects player vampires in statue form too
(0032069)
wheals (administrator)
2018-01-30 05:48

Fixed in https://github.com/crawl/crawl/commit/307c7c380388 [^]
(0032070)
wheals (administrator)
2018-01-30 05:51

Player vampires in statue form being immune to Dispel Undead could arguably go either way, I'm not as sure what the ideal behavior there should be.

- Issue History
Date Modified Username Field Change
2017-12-06 17:55 hexaflexagon New Issue
2017-12-06 17:59 hexaflexagon Note Added: 0031959
2018-01-30 05:48 wheals Note Added: 0032069
2018-01-30 05:48 wheals Status new => resolved
2018-01-30 05:48 wheals Fixed in Branch => 0.22 development branch
2018-01-30 05:48 wheals Resolution open => done
2018-01-30 05:48 wheals Assigned To => wheals
2018-01-30 05:51 wheals Note Added: 0032070


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker