Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011283 [DCSS] Bug Report major have not tried 2017-11-19 09:38 2019-02-07 23:35
Reporter stoneychips View Status public  
Assigned To ebering
Priority normal Resolution done  
Status resolved   Product Branch 0.21 ancient branch
Summary 0011283: Dark areas in Shoals look totally black
Description I left Shoals 4 for a long period after a difficult initial entrance, and returned after Vaults, Crypt and Depths. Upon returning to the branch today, darker areas in all of Shoals now seem to appear plain black. It's difficult to navigate without being able to see the ground (or water?) there clearly.

Trunk, Tiles, Win 10, Chrome, Nvidia
Additional Information
Tags No tags attached.
Attached Files jpg file icon black shoals.jpg [^] (191,200 bytes) 2017-11-19 09:38
txt file icon Loopi (stoneychips) in Dark Shoals (morgue) 11-19-2017.txt [^] (52,804 bytes) 2017-11-19 17:26 [Show Content]
jpg file icon Dark shoals in normal view (Firefox).jpg [^] (274,018 bytes) 2017-11-19 17:45

- Relationships
related to 0011780closedebering enemy or Hep ancestor icon is not erased (also, player icon during autotravel) 

-  Notes
(0031921)
advil (administrator)
2017-11-19 16:25

Very odd. Can you upload your save, as well?
(0031925)
stoneychips (reporter)
2017-11-19 17:26

Btw, I did try walking around a few steps and fighting on the level (thus the corpses you see). Went back upstairs once and returned again. I thought maybe the black was just an odd form of the initial screen, but it hasn't gone away.

Uploaded morgue.
(0031926)
advil (administrator)
2017-11-19 17:30

oh, this is webtiles, I thought it was local tiles for some reason. I should have phrased it: can you make a save file backup? Some instructions here: https://crawl.develz.org/wiki/doku.php?id=mantis:savebackup [^]

Thanks.
(0031927)
stoneychips (reporter)
2017-11-19 17:44

"Do you believe this?" So I tried looking in MS Edge and Firefox. The game appears normal in those. Then I came back to Chrome. For whatever reason, now it appears normal again in Chrome too! I don't know if you did something behind the curtain or it just changed its mind while I was off to dinner, but it seems to be okay again.

Btw, Chrome in particular and the game in general has been taking a really long time on the Loading... screen lately (although the Viet internet has generally been a touch slower probably due to broken cables, that usually doesn't hit Crawl quite this hard), such that I usually hit reload and then it wakes up faster again. Dunno if all this has anything to do with it.
(0031928)
stoneychips (reporter)
2017-11-19 17:49

I'm seeing about the Online backup system too for reference. Working on it.
(0031929)
stoneychips (reporter)
2017-11-19 17:55

What port do I put in to get to CPO? I tried with the default Putty gave as port 22,but it seems not to recognize me.
(0031930)
advil (administrator)
2017-11-19 17:58

Oh, it seems that console logins aren't possible for CPO, so I guess one would have to ask the admin to do a save backup. However, given your update that everything looks normal, I suspect I wouldn't see anything in the save backup. We didn't do anything behind the scenes, so I'm guessing it's a weird interaction with browser caching or something like that.
(0031931)
stoneychips (reporter)
2017-11-19 17:59

Okay, well thanks for answering! I don't mind if you want to downgrade it to minor, given that it's worked out ;) Scary inky black stuff though. Heh.
(0031945)
Yermak (reporter)
2017-11-24 14:11

I've experienced this several times in Firefox in the past. Mostly as a viewer. The last time was very long ago.
Fix that always worked for Me: hover the mouse over the minimap, hold down right button and move it around.
(0031946)
stoneychips (reporter)
2017-11-24 14:43

Wow, that's a tricky one to remember, but nice to have ideas if it happens again. Thanks!
(0032913)
ebering (developer)
2019-01-10 19:27

I suspect this is related to 11780 and out of order javascript messages, which have a tentative fix. If any of the reporters see this behavior continue after Jan 7, 2019 please report back.
(0033063)
ebering (developer)
2019-02-07 23:35

It seems that this was resolved successfully by 0.23-a0-654-g63bca24c07. Please re-open this bug if the problem returns.

- Issue History
Date Modified Username Field Change
2017-11-19 09:38 stoneychips New Issue
2017-11-19 09:38 stoneychips File Added: black shoals.jpg
2017-11-19 16:25 advil Note Added: 0031921
2017-11-19 17:26 stoneychips File Added: Loopi (stoneychips) in Dark Shoals (morgue) 11-19-2017.txt
2017-11-19 17:26 stoneychips Note Added: 0031925
2017-11-19 17:30 advil Note Added: 0031926
2017-11-19 17:44 stoneychips Note Added: 0031927
2017-11-19 17:45 stoneychips File Added: Dark shoals in normal view (Firefox).jpg
2017-11-19 17:49 stoneychips Note Added: 0031928
2017-11-19 17:55 stoneychips Note Added: 0031929
2017-11-19 17:58 advil Note Added: 0031930
2017-11-19 17:59 stoneychips Note Added: 0031931
2017-11-24 14:11 Yermak Note Added: 0031945
2017-11-24 14:43 stoneychips Note Added: 0031946
2019-01-10 19:20 ebering Relationship added related to 0011657
2019-01-10 19:21 ebering Relationship deleted related to 0011657
2019-01-10 19:23 ebering Relationship added related to 0011780
2019-01-10 19:27 ebering Note Added: 0032913
2019-02-07 23:35 ebering Note Added: 0033063
2019-02-07 23:35 ebering Status new => resolved
2019-02-07 23:35 ebering Fixed in Branch => 0.24 development branch
2019-02-07 23:35 ebering Resolution open => done
2019-02-07 23:35 ebering Assigned To => ebering


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker