Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011258 [DCSS] Bug Report minor always 2017-10-14 11:57 2017-12-08 23:19
Reporter NormalPerson7 View Status public  
Assigned To advil
Priority normal Resolution done  
Status closed   Product Branch 0.21 ancient branch
Summary 0011258: Skill target setting is buggy
Description There are a few always-reproducible bugs regarding target setting:

Firstly, you can set targets lower than your current skill level;

Secondly, setting targets when a target is already set sometimes arbitrarily the target is set for 27, some individual cases are listed below:

- Setting the target to a two-digit whole number eg. 20, then trying to set it to a one-digit whole number using eg. "7", not "7." or "7.0", results in the target being set at 27.

- Setting the target to a one-digit whole number eg. 9, then adjusting the target to a two-digit whole number like "21", not "21." or "21.0", sets the
target to 27.

Thirdly, when not interacting with the previous bugs, setting a target from a decimal number to a whole number, using eg. "11", not "11." or "11.0", will result in the decimal part being retained, for example:

- Setting the target to "4.5", then setting it to "9", not "9." or "9.0", will result in the target being set for 9.5.

- Setting the target to "21.8", then setting it to "11", not "11." or "11.0", will result in the target being set for 11.8.

- However, due to the previous bug, setting the target from "9.5" to "11", not "11." or "11.0", will result being set for 27 instead - this applies in the other direction as well.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0031884)
advil (administrator)
2017-10-14 14:35
edited on: 2017-10-14 14:36

Thanks for reporting, this is fixed in 0.21-a0-365-g814e052. (Except for the ability to set targets lower than your skill, which isn't a bug exactly, though I may eventually remove it -- these targets will be reached immediately, next time the target check is called.)


- Issue History
Date Modified Username Field Change
2017-10-14 11:57 NormalPerson7 New Issue
2017-10-14 14:35 advil Note Added: 0031884
2017-10-14 14:35 advil Status new => resolved
2017-10-14 14:35 advil Fixed in Branch => 0.21 development branch
2017-10-14 14:35 advil Resolution open => done
2017-10-14 14:35 advil Assigned To => advil
2017-10-14 14:36 advil Note Edited: 0031884
2017-12-08 23:19 NormalPerson7 Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker