Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011257 [DCSS] Bug Report trivial always 2017-10-11 22:20 2017-12-17 12:00
Reporter NormalPerson7 View Status public  
Assigned To advil
Priority normal Resolution done  
Status closed   Product Branch 0.21 ancient branch
Summary 0011257: HP text is still blue after berserk has ended.
Description After berserk ends and the "-Berserk" status obtained, the HP bar remains blue as if raised by something.

It appears that one of the conditions for the HP text turning blue is "Berserk" on the status bar - as "-Berserk" contains this string, it is being taken as if the player were berserked.

Reproduce:
Go berserk
Wait for berserk to end
After berserk ends, HP bar text is blue

This has been in existence ever since the change from Exh to -Berserk.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0031878)
advil (administrator)
2017-10-12 17:37

Was this also from the "subside" messaging? (I can't replicate the bug as reported but I haven't tried on webtiles.) I have clarified the messaging in https://github.com/crawl/crawl/commit/b7bfbb70b25c [^] since this was inconsistent with how we use "subside" elsewhere.
(0031879)
advil (administrator)
2017-10-12 17:40

Ok, I did replicate this one in webtiles.
(0031880)
advil (administrator)
2017-10-12 18:10

This is fixed in 0.21-a0-360-g65c131b, thanks for reporting!

- Issue History
Date Modified Username Field Change
2017-10-11 22:20 NormalPerson7 New Issue
2017-10-12 17:37 advil Note Added: 0031878
2017-10-12 17:40 advil Note Added: 0031879
2017-10-12 18:10 advil Note Added: 0031880
2017-10-12 18:10 advil Status new => resolved
2017-10-12 18:10 advil Fixed in Branch => 0.21 development branch
2017-10-12 18:10 advil Resolution open => done
2017-10-12 18:10 advil Assigned To => advil
2017-12-17 12:00 NormalPerson7 Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker