Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011229 [DCSS] Bug Report minor have not tried 2017-09-17 01:33 2018-08-26 22:40
Reporter Yermak View Status public  
Assigned To advil
Priority normal Resolution done  
Status closed   Product Branch 0.21 ancient branch
Summary 0011229: Aborting "Really passwall" costs a turn.
Description If you press 'n' in response to

"Really passwall into a travel-excluded area?"

then you still waste a turn.
Additional Information
Tags No tags attached.
Attached Files

- Relationships
duplicate of 0006571resolvedadvil aborted Passwall into excluded areas still costs MP (and time) 

-  Notes
(0031905)
Yermak (reporter)
2017-10-26 03:20

At the second glance this issue doesn't seem as simple. If passwall goes through unknown squares on its way to exclusion then it indeed yields some extra information to the player and should take some time therefore. Should prompt behaviour differ for these situations?

Also imagine the following situation:

@#X#.

# is rock wall, X - excluded unknown square. If excluded square is a rock wall, passwall will not be interrupted by the prompt. If this square is empty, the prompt will be issued. Is this wrong?
(0032256)
advil (administrator)
2018-05-24 21:52

This should be fixed in https://github.com/crawl/crawl/commit/cae90e3dcecc [^]

The new behavior is supposed to use a turn iff you learned something new relative to the state of the map.

- Issue History
Date Modified Username Field Change
2017-09-17 01:33 Yermak New Issue
2017-10-26 03:20 Yermak Note Added: 0031905
2018-05-24 21:52 advil Note Added: 0032256
2018-05-24 21:52 advil Status new => resolved
2018-05-24 21:52 advil Fixed in Branch => 0.22 development branch
2018-05-24 21:52 advil Resolution open => done
2018-05-24 21:52 advil Assigned To => advil
2018-05-24 21:53 advil Relationship added duplicate of 0006571
2018-08-26 22:40 Yermak Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker