Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011206 [DCSS] Bug Report crash have not tried 2017-09-01 05:51 2017-09-02 00:50
Reporter zelig81 View Status public  
Assigned To amalloy
Priority normal Resolution done  
Status resolved   Product Branch 0.20 ancient branch
Summary 0011206: ASSERT(attack_counts.size() == 1) in 'describe.cc' at line 3048 failed.
Description When I've cast Glaciate in ziggurat - the game crashed with error:

ASSERT(attack_counts.size() == 1) in 'describe.cc' at line 3048 failed.
Additional Information
Tags No tags attached.
Attached Files ? file icon Zocetum.cs [^] (1,936,019 bytes) 2017-09-01 05:51
txt file icon crash-Zocetum-20170901-063606.txt [^] (53,081 bytes) 2017-09-01 05:53 [Show Content]

- Relationships

-  Notes
(0031805)
amalloy (developer)
2017-09-01 07:32

Thanks for the report. I've reproduced the problem in latest trunk: when you kill a hydra with Glaciate, you sometimes get a hydra-shaped block of ice. When you look at the description for that monster (which mousing over it does, in local tiles), the game crashes, because it expects all hydra-shaped monsters to have a melee attack, but hydra-shaped blocks of ice don't have any. The same thing would happen if you could get Zin to turn a hydra into a pillar of salt, but I don't think that's actually possible without wizmode cheating.

We should be able to fix it pretty soon.
(0031808)
amalloy (developer)
2017-09-02 00:50

Fixed in https://github.com/crawl/crawl/commit/9d9b8e484c27 [^]

- Issue History
Date Modified Username Field Change
2017-09-01 05:51 zelig81 New Issue
2017-09-01 05:51 zelig81 File Added: Zocetum.cs
2017-09-01 05:53 zelig81 File Added: crash-Zocetum-20170901-063606.txt
2017-09-01 07:32 amalloy Note Added: 0031805
2017-09-02 00:50 amalloy Note Added: 0031808
2017-09-02 00:50 amalloy Status new => resolved
2017-09-02 00:50 amalloy Fixed in Branch => 0.21 development branch
2017-09-02 00:50 amalloy Resolution open => done
2017-09-02 00:50 amalloy Assigned To => amalloy


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker